maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] (MDEP-439) maven-dependency-plugin not compatible with Java 8
Date Mon, 28 Apr 2014 06:32:10 GMT

     [ https://jira.codehaus.org/browse/MDEP-439?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olivier Lamy reassigned MDEP-439:
---------------------------------

    Assignee: Olivier Lamy  (was: Mirko Friedenhagen)

> maven-dependency-plugin not compatible with Java 8
> --------------------------------------------------
>
>                 Key: MDEP-439
>                 URL: https://jira.codehaus.org/browse/MDEP-439
>             Project: Maven Dependency Plugin
>          Issue Type: Bug
>          Components: analyze
>    Affects Versions: 2.8
>         Environment: Java 8
>            Reporter: Steven Schlansker
>            Assignee: Olivier Lamy
>            Priority: Critical
>
> maven-dependency-plugin uses asm 3.x, which is not compatible with Java 8 (throws ArrayIndexOutOfBoundsException)
> This seriously hinders the use of Maven with Java 8, which is now the "production" version
of Java.



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message