maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5532) Adding repository error running mvn clean
Date Sun, 05 Jan 2014 20:57:45 GMT

     [ https://jira.codehaus.org/browse/MNG-5532?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte closed MNG-5532.
-------------------------------

    Resolution: Not A Bug
      Assignee: Robert Scholte

To be correct: this is not a Maven bug, but an Eclipse Tycho/Equinox issue and should be reported
there. I found [this thread|http://dev.eclipse.org/mhonarc/lists/tycho-user/msg04916.html]
which might help.
                
> Adding repository error running mvn clean
> -----------------------------------------
>
>                 Key: MNG-5532
>                 URL: https://jira.codehaus.org/browse/MNG-5532
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: Artifacts and Repositories
>    Affects Versions: 3.1.1
>         Environment: Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-17
11:22:22-0400)
> Maven home: C:\apache-maven-3.1.1
> Java version: 1.7.0_40, vendor: Oracle Corporation
> Java home: C:\Java\jdk1.7.0.40-x64\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
>            Reporter: Gregg Stewart
>            Assignee: Robert Scholte
>         Attachments: debug.log
>
>
> Problem:
> While running "mvn clean" I receive some exceptions while:
> Adding repository http://download.eclipse.org/eclipse/updates/license
> The -X debug output has been attached to see the full error. I've also provided instructions
on how I receive this error.
> The first exception is:
> java.lang.ClassCastException: org.eclipse.tycho.p2.remote.RemoteMetadataRepositoryManager
cannot be cast to org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager
> I have to admit that I'm pretty new to building eclipse and using maven. My apologies
if this is not a valid bug. I'm doing some more research to see if I am missing something.
> I'm not clear whether this is a problem with Maven or the maybe the POM. I'm opening
the bug under Maven since I found this at the end of the error:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/InternalErrorException
> I believe I received something similar while using the eclipse plugin so decided to download/use
apache maven outside of eclipse to see if i received the same problem. After extracting maven,
changing some maven environment variables, i re-extracted the zip i downloaded and tried using
the mvn binary. But it looks like it failed in the same place. 
> STEPS TO REPRODUCE:
> 1. Go to http://download.eclipse.org/eclipse/downloads/drops4/R-4.3.1-201309111000/
> 2. click the link for "View the repositories used for the current build." 
> 3. copy/paste the URL for: http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/commit?id=629251e64d8bebd34caca0939ee2e4c460eee609
> 4. download the file: 	eclipse.platform.releng.aggregator-629251e64d8bebd34caca0939ee2e4c460eee609.zip
> 5. rename my existing .m2 repository folder to .m2.old (because I had a bunch of stuff
in there from training stuff).
> 6. extract the file from step 4 to my C:\apache-maven-3.1.1 directory.
> 7. open a command prompt and cd to the directory:  C:\apache-maven-3.1.1\eclipse.platform\eclipse.platform.releng.tychoeclipsebuilder\platform
> 8. run: mvn clean
> 9. receive error while:
> Adding repository http://download.eclipse.org/eclipse/updates/license
> Kind regards,
> Gregg

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message