maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wouter de Vaal (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-4660) Use of --resume-from in multi-module project fails with missing inter-module dependencies
Date Thu, 02 Jan 2014 10:35:45 GMT

    [ https://jira.codehaus.org/browse/MNG-4660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=337993#comment-337993
] 

Wouter de Vaal commented on MNG-4660:
-------------------------------------

We are using an optimized automated build that uses resume-from. Resolving via install is
not a good option, as we have multiple branches building the same code. So resolving locally
would really help us.
                
> Use of --resume-from in multi-module project fails with missing inter-module dependencies
> -----------------------------------------------------------------------------------------
>
>                 Key: MNG-4660
>                 URL: https://jira.codehaus.org/browse/MNG-4660
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: Reactor and workspace
>    Affects Versions: 2.2.1, 3.0-beta-1
>         Environment: Apache Maven 2.2.1 (r801777; 2009-08-06 12:16:01-0700)
> Java version: 1.6.0_17
> Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
> Default locale: en_US, platform encoding: UTF-8
> OS name: "mac os x" version: "10.6.3" arch: "x86_64" Family: "mac"
>            Reporter: Brian Ferris
>             Fix For: Issues to be reviewed for 3.x
>
>         Attachments: modules-parent.tar.gz
>
>
> In a simple multi-module project with a parent pom "modules-parent", two sub modules
"module-a" and "module-b", where B depends on A, I've not been able to get the Maven "--resume-from"
feature to work.
> Specifically, I expect:
> > mvn --resume-from module-b test
> would resume execution of the "test" goal in "module-b".  Instead it fails with a missing
artifact error:
> > [INFO] Failed to resolve artifact.
> > 
> > Missing:
> > ----------
> > 1) org.test:module-a:jar:0.0.1-SNAPSHOT
> Why isn't Maven resolving the within-multi-module dependency?  I've attached a simple
project that reproduces the problem with Maven 2.2.1 and Maven 3.0-beta-1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message