maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andres Danter (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MPOM-45) RPM Plugin does not check if rpm-build is installed prior to attempting to build RPMs
Date Tue, 25 Jun 2013 16:33:19 GMT
Andres Danter created MPOM-45:
---------------------------------

             Summary: RPM Plugin does not check if rpm-build is installed prior to attempting
to build RPMs
                 Key: MPOM-45
                 URL: https://issues.apache.org/jira/browse/MPOM-45
             Project: Maven POMs
          Issue Type: Improvement
          Components: maven-plugins
            Reporter: Andres Danter
            Priority: Minor


This is something I recently ran into.  The package for rpm-build was not installed on the
system.  The MAVEN RPM plugin did not give a very good verbose reason for why the RPM build
failed.  Currently, it echoes the string of commands it tried to run:

[ERROR] Failed to execute goal org.codehaus.mojo:rpm-maven-plugin:2.0-beta-2:rpm (default-cli)
on project accumulo: RPM build execution returned: '127' executing '/bin/sh -c cd /home/user/accumulo/accumulo-1.4.3/target/rpm/SPECS
&& rpmbuild -bb --buildroot /home/user/accumulo/accumulo-1.4.3/target/rpm/buildroot
--define '_topdir /home/user/accumulo/accumulo-1.4.3/target/rpm' --target amd64 accumulo.spec'

A check of the availability of rpm-build prior to executing the above would have prevented
some confusion.

Thanks.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message