maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark R (JIRA)" <j...@codehaus.org>
Subject [jira] (MJAVADOC-360) JavaDoc aggregation fails (ignores deployed snapshots, complains that release versions don't satisfy the version range)
Date Thu, 10 Jan 2013 13:32:13 GMT

    [ https://jira.codehaus.org/browse/MJAVADOC-360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=317086#comment-317086
] 

Mark R commented on MJAVADOC-360:
---------------------------------

I should mention that the problem can be demonstrated very quickly by commenting out all modules
except "io7m-jcanephora-core"...
                
> JavaDoc aggregation fails (ignores deployed snapshots, complains that release versions
don't satisfy the version range)
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: MJAVADOC-360
>                 URL: https://jira.codehaus.org/browse/MJAVADOC-360
>             Project: Maven 2.x Javadoc Plugin
>          Issue Type: Bug
>    Affects Versions: 2.8.1
>         Environment: Apache Maven 3.0.4 (rNON-CANONICAL_2012-01-24_13-02_root; 2012-01-24
13:02:02+0000)
> Maven home: /opt/maven
> Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
> Java home: /usr/lib/jvm/java-6-openjdk/jre
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "linux", version: "3.6.11-1-arch", arch: "amd64", family: "unix"
> java version "1.6.0_24"
> OpenJDK Runtime Environment (IcedTea6 1.11.5) (ArchLinux-6.b24_1.11.5-1-x86_64)
> OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
>            Reporter: Mark R
>
> A multi-module project that uses a few deployed snapshots is now failing to build due
to the javadoc aggregator giving the following error:
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate
> (aggregate) on project io7m-jcanephora: An error has occurred in
> JavaDocs report generation:  Unable to find a version in [2.0.0, 2.1.0,
> 2.1.1, 2.1.2, 2.2.0, 2.3.0] to match the range
> [2.4.0-SNAPSHOT,2.4.0-SNAPSHOT],[2.4.0,3.0.0) [ERROR]
> com.io7m.jaux:io7m-jaux:jar:null
> Essentially, the aggregator seems to be saying that only the released versions (on the
Central repository) are being considered for use, and they don't fall within the range given
by the dependency on the snapshot version of that package (io7m-jaux).
> This was originally discussed on the mailing list here (to no resolution, but it was
suggested that I open this issue):
> https://mail-archives.apache.org/mod_mbox/maven-users/201301.mbox/%3C20130108140632.851A193@athena.apache.org%3E
> I have uploaded a snapshot of the project to the github repository at:
> https://github.com/io7m/io7m-jcanephora
> The README file gives two required public repositories necessary to build the project,
and recommends the use of -Dmaven.test.skip=true (as the test suite is quite intensive and
not needed here). I've been building with "mvn -C clean verify -Dmaven.test.skip=true.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message