maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] (MASSEMBLY-592) Cannot create an assembly for use during the build process
Date Mon, 05 Nov 2012 21:00:13 GMT

     [ https://jira.codehaus.org/browse/MASSEMBLY-592?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dennis Lundberg updated MASSEMBLY-592:
--------------------------------------

    Description: 
I am trying to create a zip file for use in an intermediate process. I then use that zip file
to include in an installer. I then need it to zip up the installer file to use as an artifact
for other builds. I use the plug in once in the compile step, and then once in the packaging
step. The problem is that the one in the packaging step seems to use the configuration settings
from the compile step even though they are redefined. Am I using the plug-in the wrong way?
I just need a way to build a zip to be used later in the same build project.

{code:xml}
	<plugin>
		<groupId>org.apache.maven.plugins</groupId>
		<artifactId>maven-assembly-plugin</artifactId>
		<configuration>
		<finalName>${file1.name}</finalName>
			<descriptors>
				<descriptor>${file1.name}-assembly.xml</descriptor>
			</descriptors>
		</configuration>
		<executions>
			<execution>
				<id>make-${file1.name}-assembly</id>
				<phase>compile</phase>
				<goals>
				    <goal>single</goal>
				</goals>
			</execution>
		</executions>
	</plugin>

       <!-- build the installer -->
       ...

	<plugin>
	<!-- Zip up the relevant build artifacts -->
		<groupId>org.apache.maven.plugins</groupId>
		<artifactId>maven-assembly-plugin</artifactId>
		<configuration>
			<finalName>${file2.name}</finalName>
			<descriptors>
				<descriptor>${file2.name}-assembly.xml</descriptor>
			</descriptors>
		</configuration>
		<executions>
			<execution>
				<id>make-${file2.name}-assembly</id>
				<phase>package</phase>
				<goals>
					<goal>single</goal>
				</goals>
			</execution>
		</executions>
	</plugin>
{code}


  was:
I am trying to create a zip file for use in an intermediate process. I then use that zip file
to include in an installer. I then need it to zip up the installer file to use as an artifact
for other builds. I use the plug in once in the compile step, and then once in the packaging
step. The problem is that the one in the packaging step seems to use the configuration settings
from the compile step even though they are redefined. Am I using the plug-in the wrong way?
I just need a way to build a zip to be used later in the same build project.



	<plugin>
		<groupId>org.apache.maven.plugins</groupId>
		<artifactId>maven-assembly-plugin</artifactId>
		<configuration>
		<finalName>${file1.name}</finalName>
			<descriptors>
				<descriptor>${file1.name}-assembly.xml</descriptor>
			</descriptors>
		</configuration>
		<executions>
			<execution>
				<id>make-${file1.name}-assembly</id>
				<phase>compile</phase>
				<goals>
				    <goal>single</goal>
				</goals>
			</execution>
		</executions>
	</plugin>

       <!-- build the installer -->
       ...

	<plugin>
	<!-- Zip up the relevant build artifacts -->
		<groupId>org.apache.maven.plugins</groupId>
		<artifactId>maven-assembly-plugin</artifactId>
		<configuration>
			<finalName>${file2.name}</finalName>
			<descriptors>
				<descriptor>${file2.name}-assembly.xml</descriptor>
			</descriptors>
		</configuration>
		<executions>
			<execution>
				<id>make-${file2.name}-assembly</id>
				<phase>package</phase>
				<goals>
					<goal>single</goal>
				</goals>
			</execution>
		</executions>
	</plugin>


    
> Cannot create an assembly for use during the build process
> ----------------------------------------------------------
>
>                 Key: MASSEMBLY-592
>                 URL: https://jira.codehaus.org/browse/MASSEMBLY-592
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2.2
>            Reporter: D'ar Gog
>
> I am trying to create a zip file for use in an intermediate process. I then use that
zip file to include in an installer. I then need it to zip up the installer file to use as
an artifact for other builds. I use the plug in once in the compile step, and then once in
the packaging step. The problem is that the one in the packaging step seems to use the configuration
settings from the compile step even though they are redefined. Am I using the plug-in the
wrong way? I just need a way to build a zip to be used later in the same build project.
> {code:xml}
> 	<plugin>
> 		<groupId>org.apache.maven.plugins</groupId>
> 		<artifactId>maven-assembly-plugin</artifactId>
> 		<configuration>
> 		<finalName>${file1.name}</finalName>
> 			<descriptors>
> 				<descriptor>${file1.name}-assembly.xml</descriptor>
> 			</descriptors>
> 		</configuration>
> 		<executions>
> 			<execution>
> 				<id>make-${file1.name}-assembly</id>
> 				<phase>compile</phase>
> 				<goals>
> 				    <goal>single</goal>
> 				</goals>
> 			</execution>
> 		</executions>
> 	</plugin>
>        <!-- build the installer -->
>        ...
> 	<plugin>
> 	<!-- Zip up the relevant build artifacts -->
> 		<groupId>org.apache.maven.plugins</groupId>
> 		<artifactId>maven-assembly-plugin</artifactId>
> 		<configuration>
> 			<finalName>${file2.name}</finalName>
> 			<descriptors>
> 				<descriptor>${file2.name}-assembly.xml</descriptor>
> 			</descriptors>
> 		</configuration>
> 		<executions>
> 			<execution>
> 				<id>make-${file2.name}-assembly</id>
> 				<phase>package</phase>
> 				<goals>
> 					<goal>single</goal>
> 				</goals>
> 			</execution>
> 		</executions>
> 	</plugin>
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message