maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] (MASSEMBLY-317) useStrictFiltering requires dependency in all included modules
Date Fri, 02 Nov 2012 10:47:13 GMT

     [ https://jira.codehaus.org/browse/MASSEMBLY-317?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dennis Lundberg updated MASSEMBLY-317:
--------------------------------------

    Component/s: moduleSet
    
> useStrictFiltering requires dependency in all included modules
> --------------------------------------------------------------
>
>                 Key: MASSEMBLY-317
>                 URL: https://jira.codehaus.org/browse/MASSEMBLY-317
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>          Components: moduleSet
>    Affects Versions: 2.2-beta-2
>            Reporter: Thomas Diesler
>
> With this moduleSet all dependency artifacts must be defined in all included modules
> {code:xml}
>     <moduleSet>
>       <includes>
>         <include>org.jboss.ws:jbossws-cxf-server</include>
>         <include>org.jboss.ws:jbossws-cxf-client</include>
>       </includes>
>       <binaries>
>         <outputDirectory>server/default/deploy/jbossws.sar</outputDirectory>
>         <outputFileNameMapping>${module.artifactId}.${module.extension}</outputFileNameMapping>
>         <unpack>false</unpack>
>         <dependencySets>
>           <dependencySet>
>             <outputFileNameMapping>${module.artifactId}.${module.extension}</outputFileNameMapping>
>             <useStrictFiltering>true</useStrictFiltering>
>             <includes>
>               <include>*:cxf-*</include>
>               <include>*:geronimo-javamail*</include>
>               <include>*:geronimo-ws-metadata*</include>
>               <include>*:jaxrpc-api*</include>
>               <include>*:jaxws-api*</include>
>               <include>*:neethi*</include>
>               <include>*:saaj-api*</include>
>               <include>*:saaj-impl*</include>
>               <include>*:spring-beans*</include>
>               <include>*:spring-context*</include>
>               <include>*:spring-core*</include>
>               <include>*:wsdl4j*</include>
>               <include>*:xml-resolver*</include>
>               <include>*:XmlSchema*</include>
>             </includes>
>           </dependencySet>
>         </dependencySets>
>       </binaries>
>     </moduleSet>
> {code}
> I believe this should be changed such that the dependency is satisfied by at least one
module.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message