maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Walton (JIRA)" <j...@codehaus.org>
Subject [jira] (MSHADE-103) maven-shade-plugin does not resolve from user-defined repositories
Date Fri, 01 Jun 2012 05:35:21 GMT

    [ https://jira.codehaus.org/browse/MSHADE-103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=300161#comment-300161
] 

Joseph Walton edited comment on MSHADE-103 at 6/1/12 12:34 AM:
---------------------------------------------------------------

I have a case where the "remote" repository is a local directory and the local repository
is configured to keep the build isolated.

In MSHADE-103.tar.gz, with {{settings.xml}} configured with local paths:

{code}
mvn3 --settings settings.xml clean package
{code}

fails to find the parent pom even though it's already in the configured local repository.

The dependency is an arbitrary choice of jar. If it's removed then the shading succeeds. Shading
also succeeds when createDependencyReducedPom is set to false.
                
      was (Author: joewalton):
    I have a case where the "remote" repository is a local directory and the local repository
is configured to keep the build isolated.

In MSHADE-103.tar.gz, with {{settings.xml}} configured with local paths:

{code}
mvn3 --settings settings.xml clean package
{code}

fails to find the parent pom even though it's already in the configured local repository.

The dependency is an arbitrary choice of jar. If it's removed then the shading succeeds.
                  
> maven-shade-plugin does not resolve from user-defined repositories
> ------------------------------------------------------------------
>
>                 Key: MSHADE-103
>                 URL: https://jira.codehaus.org/browse/MSHADE-103
>             Project: Maven 2.x Shade Plugin
>          Issue Type: Bug
>    Affects Versions: 1.3.3, 1.4
>         Environment: Maven 3.0.3 (works with 2.2.1)
>            Reporter: Lukas Fryc
>         Attachments: MSHADE-103.tar.gz
>
>
> maven-shade-plugin doesn't consult repositories defined in 
> settings.xml when trying to resolve parents of given pom. It contacts 
> only central repo: 
> [ERROR] Failed to execute goal 
> org.apache.maven.plugins:maven-shade-plugin:1.4:shade (default) on 
> project richfaces-components-api: Error creating shaded jar: 1 problem 
> was encountered while building the effective model for 
> org.richfaces.ui:richfaces-components-api:4.1.0-SNAPSHOT 
> [ERROR] [FATAL] Non-resolvable parent POM for 
> org.richfaces:richfaces-bom:4.1.0-SNAPSHOT: Could not find artifact 
> org.richfaces:richfaces-parent:pom:10 in central 
> (http://repo1.maven.org/maven2) and 'parent.relativePath' points at 
> wrong local POM @ org.richfaces:richfaces-bom:4.1.0-SNAPSHOT, 
> /home/lfryc/workspaces/richfaces/build/bom/pom.xml, line 24, column 10 
> [ERROR] for project 
> org.richfaces.ui:richfaces-components-api:4.1.0-SNAPSHOT at 
> /home/lfryc/workspaces/richfaces/components/dist/richfaces-components-api/dependency-reduced-pom.xml

> for project org.richfaces.ui:richfaces-components-api:4.1.0-SNAPSHOT at 
> /home/lfryc/workspaces/richfaces/components/dist/richfaces-components-api/dependency-reduced-pom.xml

> [ERROR] -> [Help 1] 
> There is affected project (it references version 1.3.3, but the behavior is same with
1.4) if you would like to try at own: 
> https://github.com/richfaces/components/blob/develop/dist/richfaces-components-api/pom.xml

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message