maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@codehaus.org>
Subject [jira] (MRELEASE-58) Update the release.properties if pom.xml have been updated (SCM
Date Thu, 03 May 2012 18:40:02 GMT

     [ https://jira.codehaus.org/browse/MRELEASE-58?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte updated MRELEASE-58:
-----------------------------------

    Description: 
I experienced the same troubles as described in http://www.nabble.com/-M2-What-is-wrong-with-my-scm-url--t480810.html#a1308659
.
The build error print :

{noformat}
Embedded error: Can't load the scm provider.
No such provider: 'rver'.
{noformat}

And with {{mvn -X}} give me : 

{noformat}
[DEBUG]   Artifact resolved
[DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-release-plugin:2.0-beta-4-SNAPSHOT:prepare'
-->
[DEBUG]   (f) basedir = /projects/jing-trang
[DEBUG]   (f) generateReleasePoms = false
[DEBUG]   (f) interactive = true
[DEBUG]   (f) localRepository = [local] -> file:///home/ehartmann/.m2/repository
[DEBUG]   (f) reactorProjects = [org.apache.maven.project.MavenProject@a441ef04]
[DEBUG]   (f) resume = true
[DEBUG]   (f) settings = org.apache.maven.settings.Settings@17f1841
[DEBUG]   (f) tagBase = ../tags
[DEBUG]   (f) urlScm = cvs:pserver:cvs.sharedvalue.com:/opt/cvs/:jing-trang
[DEBUG] -- end configuration --
{noformat}

Unfortunately I was not aware of the url is taken in {{release.properties}} (since the urlScm
is right in the debug log) and look for this issue for a couple of hours before finding the
explanation in the mailing list.
It may be usefull to recreate {{release.properties}} if pom.xml have been updated since it's
creation and/or log the information taken in {{release.properties}} to give a hint to developers
(who have not carefully read http://maven.apache.org/scm as myself :-)) that made an error
in the scm url.

I create a new bug report instead of MNG-1105 as I think it's not quite the same.

  was:
I experienced the same troubles as described in http://www.nabble.com/-M2-What-is-wrong-with-my-scm-url--t480810.html#a1308659
.
The build error print :

Embedded error: Can't load the scm provider.
No such provider: 'rver'.

And with mvn -X give me : 

[DEBUG]   Artifact resolved
[DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-release-plugin:2.0-beta-4-SNAPSHOT:prepare'
-->
[DEBUG]   (f) basedir = /projects/jing-trang
[DEBUG]   (f) generateReleasePoms = false
[DEBUG]   (f) interactive = true
[DEBUG]   (f) localRepository = [local] -> file:///home/ehartmann/.m2/repository
[DEBUG]   (f) reactorProjects = [org.apache.maven.project.MavenProject@a441ef04]
[DEBUG]   (f) resume = true
[DEBUG]   (f) settings = org.apache.maven.settings.Settings@17f1841
[DEBUG]   (f) tagBase = ../tags
[DEBUG]   (f) urlScm = cvs:pserver:cvs.sharedvalue.com:/opt/cvs/:jing-trang
[DEBUG] -- end configuration --

Unfortunately I was not aware of the url is taken in release.properties (since the urlScm
is right in the debug log) and look for this issue for a couple of hours before finding the
explanation in the mailing list.
It may be usefull to recreate release.properties if pom.xml have been updated since it's creation
and/or log the information taken in release.properties to give a hint to developers (who have
not carefully read http://maven.apache.org/scm as myself :-)) that made an error in the scm
url.

I create a new bug report instead of http://jira.codehaus.org/browse/MNG-1105 as I think it's
not quite the same.

    
> Update the release.properties if pom.xml have been updated (SCM 
> ----------------------------------------------------------------
>
>                 Key: MRELEASE-58
>                 URL: https://jira.codehaus.org/browse/MRELEASE-58
>             Project: Maven 2.x Release Plugin
>          Issue Type: Bug
>          Components: scm
>            Reporter: Eric Hartmann
>
> I experienced the same troubles as described in http://www.nabble.com/-M2-What-is-wrong-with-my-scm-url--t480810.html#a1308659
.
> The build error print :
> {noformat}
> Embedded error: Can't load the scm provider.
> No such provider: 'rver'.
> {noformat}
> And with {{mvn -X}} give me : 
> {noformat}
> [DEBUG]   Artifact resolved
> [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-release-plugin:2.0-beta-4-SNAPSHOT:prepare'
-->
> [DEBUG]   (f) basedir = /projects/jing-trang
> [DEBUG]   (f) generateReleasePoms = false
> [DEBUG]   (f) interactive = true
> [DEBUG]   (f) localRepository = [local] -> file:///home/ehartmann/.m2/repository
> [DEBUG]   (f) reactorProjects = [org.apache.maven.project.MavenProject@a441ef04]
> [DEBUG]   (f) resume = true
> [DEBUG]   (f) settings = org.apache.maven.settings.Settings@17f1841
> [DEBUG]   (f) tagBase = ../tags
> [DEBUG]   (f) urlScm = cvs:pserver:cvs.sharedvalue.com:/opt/cvs/:jing-trang
> [DEBUG] -- end configuration --
> {noformat}
> Unfortunately I was not aware of the url is taken in {{release.properties}} (since the
urlScm is right in the debug log) and look for this issue for a couple of hours before finding
the explanation in the mailing list.
> It may be usefull to recreate {{release.properties}} if pom.xml have been updated since
it's creation and/or log the information taken in {{release.properties}} to give a hint to
developers (who have not carefully read http://maven.apache.org/scm as myself :-)) that made
an error in the scm url.
> I create a new bug report instead of MNG-1105 as I think it's not quite the same.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message