maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5251) Cannot use version range for plugin
Date Sun, 26 Feb 2012 17:43:02 GMT

    [ https://jira.codehaus.org/browse/MNG-5251?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=292783#comment-292783
] 

Olivier Lamy commented on MNG-5251:
-----------------------------------

for build reproducibility, I think IMHO this is something we must *NOT* support.
what will happened for something [1.0,), you will use SNAPSHOT sometimes (depending on available
plugin repositories in your settings).

+1 to mark as Won't fix.
 
                
> Cannot use version range for plugin
> -----------------------------------
>
>                 Key: MNG-5251
>                 URL: https://jira.codehaus.org/browse/MNG-5251
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: POM
>    Affects Versions: 3.0.4
>         Environment: Windows 7 SP1, Java 1.6u29
>            Reporter: Michal Michalski
>
> There's no way for use version ranges for plugins in POM, like this:
> {code:xml}
> <project ...>
>   ...
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>jboss-packaging-maven-plugin</artifactId>
>         <version>[2.1, 2.2]</version>
>         <extensions>true</extensions>
>       </plugin>
>     </plugins>
>   </build>
>   ...
> </project>
> {code}
> I've also tried use of version range in {{<pluginManagement />}}, but still doesn't
work.
> Console output after {{mvn package}}:
> {code}
> [ERROR] Plugin org.codehaus.mojo:jboss-packaging-maven-plugin:[2.1, 2.2] or one of its
dependencies could not be resolved: Failed to read ar
> tifact descriptor for org.codehaus.mojo:jboss-packaging-maven-plugin:jar:[2.1, 2.2]:
Could not transfer artifact org.codehaus.mojo:jboss-pac
> kaging-maven-plugin:pom:[2.1, 2.2] from/to Custom-repo-plugins (http://nexus:8080/nexus/content/groups/custom):
IllegalArgumentException: Ille
> gal character in path at index 93: http:/nexus:8080/nexus/content/groups/custom/org/codehaus/mojo/jboss-packaging-maven-plugin/[2.1,
2.2
> ]/jboss-packaging-maven-plugin-[2.1, 2.2].pom -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message