maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arne.Reinhardt (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-4996) Maven3 parallel build fails occasionally for classpath problems.
Date Fri, 30 Sep 2011 14:55:17 GMT

    [ https://jira.codehaus.org/browse/MNG-4996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=280386#comment-280386
] 

Arne.Reinhardt commented on MNG-4996:
-------------------------------------

I observed a similar behaviour in a build containing some 140 modules.
The build made heavy use of the antrun plugin to trigger custom generators and I observed
two kinds of effects:
* java tasks executed via antrun did not find their main class
* compiles did not find any libraries

These effects appeared rather randomly revealing the kinds of broken classpaths described
by Kari (classpath containing only the module's output directory).

Now I seem to have resolved the problem by supplying explicit versions of both the maven-ejb-plugin
and the maven-source-plugin (which had been forgotten before).
The astonishing thing about this is that I had defined *exactly* those (threadsafe) versions
of the plugins which in the broken builds maven had figured out to use by itself. Moreover
I observed that the modules whose builds had been broken by the missing versions did not have
to use these plugins (at least not both of them, but I think they always used at least the
maven-source-plugin).
And it appears thet the effect cannot be reproduced by simply leaving off *one* of the versions.
I need to remove both version numbers to see the build broken (but maybe this simply increases
the probability).

So my impression is that not the usage of a non-threadsafe plugin causes the problem but rather
the absence of version definitions.

At least my build seems stable now ;)

> Maven3 parallel build fails occasionally for classpath problems.
> ----------------------------------------------------------------
>
>                 Key: MNG-4996
>                 URL: https://jira.codehaus.org/browse/MNG-4996
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: Plugins and Lifecycle
>    Affects Versions: 3.0.1
>         Environment: maven 3.0.1, maven 3.0
>            Reporter: Kari J. Niemi
>            Assignee: Kristian Rosenvold
>
> In a multimodule (>120 modules) maven build, the compiler plug-in would seem to fail
in creating a correct class-path every now and then.
> Instead of this entry in maven -X logs for a single module build:
> ----
> [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile'
with basic configurator -->
> ..
> [DEBUG]   (f) classpathElements = [/home/karniemi/"mymodulepath"/target/classes, /home/karniemi/.m2/repository/org/apache/servicemix/servicemix-utils/1.2.0/servicemix-utils-1.2.0.jar,
/home/karniemi/.m2/repository/org/apache/geronimo/specs/geronimo-stax-api_1.0_spec/1.0.1/geronimo-stax-api_1.0_spec-1.0.1.jar,
/home/karniemi/.m2/repository/org/codehaus/woodstox/wstx-asl/3.2.6/wstx-asl-3.2.6.jar, /home/karniemi/.m2/repository/org/apache/servicemix/specs/org.apache.servicemix.specs.jbi-api-1.0/1.4.0/org.apache.servicemix.specs.jbi-api-1.0-1.4.0.jar,
/home/karniemi/.m2/repository/org/apache/geronimo/specs/geronimo-activation_1.1_spec/1.0.2/geronimo-activation_1.1_spec-1.0.2.jar,
/home/karniemi/.m2/repository/log4j/log4j/1.2.14/log4j-1.2.14.jar]
> ----
> every now and then I get this in the parallel build:
> ----
> [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile'
with basic configurator -->
> ...
> [DEBUG]   (f) classpathElements = [/home/karniemi/"mymodulepath"/target/classes]
> ----
> And of course the compilation fails because none of the dependencies are added to the
classpath. Sometimes it goes fine in the multi-module build, but every now and then it fails
for this.
> In both maven runs I can see that the dependencies are resolved fine:
> ----------
> [DEBUG] "mymodule":jar:DYNAMIC-SNAPSHOT
> [DEBUG]    junit:junit:jar:4.7:test
> [DEBUG]    org.apache.servicemix:servicemix-utils:jar:1.2.0:provided
> [DEBUG]       org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1:provided
> [DEBUG]       org.codehaus.woodstox:wstx-asl:jar:3.2.6:provided
> [DEBUG]       org.apache.servicemix.specs:org.apache.servicemix.specs.jbi-api-1.0:jar:1.4.0:provided
(scope managed from compile) (version managed from 1.1.0)
> [DEBUG]          org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2:provided
> [DEBUG]    log4j:log4j:jar:1.2.14:provided
> -----------
>  
> The  pluginArtifactMap looks like this:
> --------------------
> [DEBUG]   (s) pluginArtifactMap = {org.apache.maven.plugins:maven-surefire-plugin=org.apache.maven.plugins:maven-surefire-plugin:maven-plugin:2.6:,
org.apache.maven.surefire:surefire-booter=org.apache.maven.surefire:surefire-booter:jar:2.6:compile,
org.apache.maven.surefire:surefire-api=org.apache.maven.surefire:surefire-api:jar:2.6:compile,
org.apache.maven.surefire:maven-surefire-common=org.apache.maven.surefire:maven-surefire-common:jar:2.6:compile,
org.apache.maven.shared:maven-common-artifact-filters=org.apache.maven.shared:maven-common-artifact-filters:jar:1.2:compile,
org.codehaus.plexus:plexus-utils=org.codehaus.plexus:plexus-utils:jar:2.0.5:compile, junit:junit=junit:junit:jar:3.8.1:compile,
org.apache.maven.reporting:maven-reporting-api=org.apache.maven.reporting:maven-reporting-api:jar:2.0.9:compile}
> --------------------
> I'm really using jbi-maven-plugin for most of the modules, and that plugin binds the
other plugins -also the compiler-plugin -to maven life-cycle phases.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message