maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Davis (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MASSEMBLY-576) addClasspath broken in new single goal
Date Wed, 14 Sep 2011 00:22:17 GMT
addClasspath broken in new single goal
--------------------------------------

                 Key: MASSEMBLY-576
                 URL: https://jira.codehaus.org/browse/MASSEMBLY-576
             Project: Maven 2.x Assembly Plugin
          Issue Type: Bug
    Affects Versions: 2.2.1
         Environment: Maven 3.0.3
Ubuntu 11.04
Sun java 6 (1.6.0_26)
            Reporter: James Davis
            Priority: Blocker


According to the documentation, using <addClasspath>true</addClasspath> in archive/manifest,
should place the generated classpath in to the manifest.  This works with assembly:assembly
(now deprecated), but is broken in assembly:single

Here is my plugin definition section:
<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-assembly-plugin</artifactId>
    <configuration>
        <descriptors>
            <descriptor>src/main/assembly/assembly.xml</descriptor>
        </descriptors>
        <archive>
            <manifest>
                <mainClass>com.example.Main</mainClass>
                <addClasspath>true</addClasspath>
                <classpathPrefix>lib/</classpathPrefix>
            </manifest>
        </archive>
    </configuration>
    <executions>
        <execution>
            <phase>package</phase>
            <goals>
                <goal>single</goal>
            </goals>
        </execution>
    </executions>
</plugin>

and the custom assembly file:
<assembly>
    <id>full</id>
    <formats>
        <format>jar</format>
    </formats>
    <includeBaseDirectory>false</includeBaseDirectory>
    <dependencySets>
        <dependencySet>
            <unpack>false</unpack>
            <scope>runtime</scope>
            <useProjectArtifact>true</useProjectArtifact>
            <outputDirectory>lib/</outputDirectory>
        </dependencySet>
    </dependencySets>
    <fileSets>
        <fileSet>
            <directory>${project.build.outputDirectory}</directory>
            <outputDirectory>/</outputDirectory>
        </fileSet>
    </fileSets>
</assembly>

I'm not sure if this is just because the documentation does not correctly address how to do
this or if it is actually just broken.  I did check the docs and this is how the docs claim
you should be able to do this.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message