maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "daivish shah (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MANTRUN-167) Maven Plugin Doesn't allow me to SETUP JDK 1.4.2 Version
Date Wed, 10 Aug 2011 19:05:42 GMT
Maven Plugin Doesn't allow me to SETUP JDK 1.4.2 Version
--------------------------------------------------------

                 Key: MANTRUN-167
                 URL: https://jira.codehaus.org/browse/MANTRUN-167
             Project: Maven 2.x Antrun Plugin
          Issue Type: Bug
    Affects Versions: 1.6
         Environment: Windows
            Reporter: daivish shah


Hi,

I am using MAVEN 2.2.1 version and trying to compile my classes from ANT script. 

I want to compile my classes with JDK 1.4.2 version. How can i do it ?

Following one is my entry which i am using EVEN i am setting up rt.jar and tools.jar with
JDK 1.4.2 in my build.xml file still my Eclipse is referring JDK 1.5 version only.


			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-antrun-plugin</artifactId>
				<version>1.6</version>
				<executions>
					<execution>
						<id>install</id>
						<phase>install</phase>
						<goals>
							<goal>run</goal>
						</goals>
						<configuration>
 							<source>${java-version}</source>
							<target>${java-version}</target>
							<tasks>
								<ant antfile="WPSEjb_build.xml" />
							</tasks>
						</configuration>
					</execution>
				</executions>
				<dependencies>
                                   <dependency>
                                         <groupId>sun.jdk</groupId>
                                         <artifactId>tools</artifactId>
                                         <version>1.4.2</version>
                                         <scope>system</scope>
                                         <systemPath>${java.home}/lib/tools.jar</systemPath>
                                    </dependency>
				</dependencies>
			</plugin>
		</plugins>


Please advice me which property is available in maven-antrun-plugin so i can set that and
my compiler use JDK 1.4.2 version ?

I am really stuck here. I am looking for your reply.

Thanks,
daivish..

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message