maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott MacDonald (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MPMD-86) Using JDK 1.5 causes ParseException: Can't use generics unless running in JDK 1.5 mode!
Date Wed, 03 Aug 2011 15:03:42 GMT

    [ https://jira.codehaus.org/browse/MPMD-86?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=274907#comment-274907
] 

Scott MacDonald commented on MPMD-86:
-------------------------------------

The workaround of setting <properties><targetJdk>1.6<targetJdk><properties>
 is not working for me.   This bug still exists in latest maven 3.0.03  PMD 2.4,  has a workaround
that does not work in all cases,  and should be reopened.

> Using JDK 1.5 causes ParseException: Can't use generics unless running in JDK 1.5 mode!
> ---------------------------------------------------------------------------------------
>
>                 Key: MPMD-86
>                 URL: https://jira.codehaus.org/browse/MPMD-86
>             Project: Maven 2.x PMD Plugin
>          Issue Type: Bug
>          Components: PMD
>    Affects Versions: 2.4
>         Environment: JAVA 1.5, Maven 2.0.9
>            Reporter: Debabrat Panda
>            Assignee: Benjamin Bentmann
>
> While running PMD with Maven i am getting parsing error "Error while parsing ../../../java
file"
> The errors are
> 1. Can't use generics unless running in JDK 1.5 mode!
> 2. Can't use static imports when running in JDK 1.4 mode!
> Can't use annotations when running in JDK 1.4 mode!
> Any help will be appreciated.
> Thanks in advance.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message