maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Theussl (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (DOXIA-437) SWF macro generates HTML tags for params without closing sign
Date Tue, 26 Jul 2011 07:19:42 GMT

     [ https://jira.codehaus.org/browse/DOXIA-437?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lukas Theussl closed DOXIA-437.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 1.3
         Assignee: Lukas Theussl

Patch applied in [r1151002|http://svn.apache.org/viewvc?rev=1151002&view=rev]. Thanks!

> SWF macro generates HTML tags  for params without closing sign
> --------------------------------------------------------------
>
>                 Key: DOXIA-437
>                 URL: https://jira.codehaus.org/browse/DOXIA-437
>             Project: Maven Doxia
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.2
>            Reporter: Andres Gomez Casanova
>            Assignee: Lukas Theussl
>             Fix For: 1.3
>
>         Attachments: SwfMacro.java.patch
>
>
> The SWF macro produces HTML code that does not closes the tags for param attributes.
> The following is the current code produced for this macro:
> %{swf|src=http://www.youtube.com/v/3W0GvjrPFj4&amp;hl=en&amp;fs=1|id=installingZemucan|width=640|height=480}
> <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,45,0"
width="640" height="480" id="installingZemucan">
> <param name="movie" value="http://www.youtube.com/v/3W0GvjrPFj4&amp;hl">
> <param name="quality" value="high">
> <param name="menu" value="false">
> <param name="loop" value="0">
> <param name="play" value="true">
> <param name="allowScriptAccess" value="sameDomain"><embed src="http://www.youtube.com/v/3W0GvjrPFj4&amp;hl"
width="640" height="480" loop="0" play="true" quality="high" allowScriptAccess="sameDomain"
pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"
menu="false">
> </embed>
> </object>
> But the correct code should be:
> <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,45,0"
width="640" height="480" id="installingZemucan">
> <param name="movie" value="http://www.youtube.com/v/3W0GvjrPFj4&amp;hl" />
> <param name="quality" value="high" />
> <param name="menu" value="false" />
> <param name="loop" value="0" />
> <param name="play" value="true" />
> <param name="allowScriptAccess" value="sameDomain" /><embed src="http://www.youtube.com/v/3W0GvjrPFj4&amp;hl"
width="640" height="480" loop="0" play="true" quality="high" allowScriptAccess="sameDomain"
pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"
menu="false">
> </embed>
> </object>
> I attached the patch that adds the final slashes for the params.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message