maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Theussl (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-546) "container" field of SiteDeployMojo not populated correctly -> NPE with servers containing configuration
Date Wed, 13 Apr 2011 10:47:22 GMT

    [ http://jira.codehaus.org/browse/MSITE-546?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=263433#action_263433
] 

Lukas Theussl commented on MSITE-546:
-------------------------------------

I don't think you are actually running 3.0-beta-4-SNAPSHOT, in the current dev version there
is no line number 474 in SiteDeployMojo: http://svn.apache.org/viewvc/maven/plugins/branches/maven-site-plugin-3.x/src/main/java/org/apache/maven/plugins/site/SiteDeployMojo.java?view=markup

> "container" field of SiteDeployMojo not populated correctly -> NPE with servers containing
configuration
> --------------------------------------------------------------------------------------------------------
>
>                 Key: MSITE-546
>                 URL: http://jira.codehaus.org/browse/MSITE-546
>             Project: Maven 2.x and 3.x Site Plugin
>          Issue Type: Bug
>          Components: Maven 3, site:deploy
>    Affects Versions: 3.0-beta-3
>            Reporter: Carl Wilund
>            Assignee: Olivier Lamy
>             Fix For: 3.0-beta-4
>
>
> In SiteDeployMojo, the field "container" is not populated correctly (version skew with
@Requirement?). When configureWagon is subsequently called, IFF the site deploy server has
an entry in settings.xml AND contains a "configuration" subelement, there will be a NullPointerException
thrown (line 474) when container.lookup is called. 
> Simple repro:
> settings.xml: 
> ...
> <server>
>       <id>bogus</id>
>       <username>bogus</username>
>       <password>bogus</password>      
>       <configuration>
>       </configuration>
>     </server>
> ...
> pom.xml:
> ...
> 	<build>
> 		<plugins>
> 			<plugin>
> 				<groupId>org.apache.maven.plugins</groupId>
> 				<artifactId>maven-site-plugin</artifactId>
> 				<version>3.0-beta-3</version>
> 			</plugin>
> 		</plugins>
> 	</build>
> 	<distributionManagement>
> 		<site>
> 			<id>bogus</id>
> 			<name>Bogus</name>
> 			<url>sftp://bogus.bogus.org/bogus</url>
> 		</site>
> 	</distributionManagement>
> ...
> While this should obviously not work, it should not NPE at line 474.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message