maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Atanu Panda (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-4995) 0% code coverage have been reported where as some unit test had been done.
Date Tue, 25 Jan 2011 06:05:58 GMT

    [ http://jira.codehaus.org/browse/MNG-4995?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=252756#action_252756
] 

Atanu Panda commented on MNG-4995:
----------------------------------

Find below the sonar result:

Code coverage

0.0%

0.0% line coverage

0.0% branch coverage

3 tests

12.9 sec


> 0% code coverage have been reported where as some unit test had been done.
> --------------------------------------------------------------------------
>
>                 Key: MNG-4995
>                 URL: http://jira.codehaus.org/browse/MNG-4995
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: Sites & Reporting
>    Affects Versions: 2.0.9
>         Environment: maven 2.2.1, maven-surefire-plugin, 2.5 and cobertura-maven-plugin
2.4
>            Reporter: Atanu Panda
>
> I have project module where I have done some junit test and found out test result. But
when I see the code coverage I found that is 0% code coverage. I have searched the jira tickets,
but I was unsuccessful
> Find below my test result snippet
> Successful Testing.....
> tearDown.....
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 8.327 sec
> Results :
> Tests run: 3, Failures: 0, Errors: 0, Skipped: 0
> I have in my pom.xml as
> <build>
> .
> .
>                                     <plugin>
> 				    <groupId>org.apache.maven.plugins</groupId>
> 				    <artifactId>maven-surefire-plugin</artifactId>
> 				    <version>2.5</version>
> 					<configuration>
> 					  <includes>
> 						<include>**/*Test*.class</include>
> 					  </includes>
> 					  <systemProperties>
> 						<property>
> 						<name>net.sourceforge.cobertura.datafile</name>
> 						<value>${project.build.directory}/cobertur/cobertura.ser</value>
> 						</property>
> 					  </systemProperties>
> 					</configuration>
> 				</plugin> 
> 				
> 				<plugin>
> 					<groupId>org.codehaus.mojo</groupId>
> 					<artifactId>cobertura-maven-plugin</artifactId>
> 					<version>2.1</version>
> 					<configuration>
> 					  <includes>
> 						<include>**/*Test*.class</include>
> 					  </includes>
> 					</configuration>
>  					<executions>
> 					  <execution>
> 						<goals>
> 						  <goal>clean</goal>
> 						  <goal>instrument</goal>
> 						  <goal>cobertura</goal>
> 						</goals>
> 					  </execution>
> 					</executions> 
> 				</plugin>
> .
> .
> </build>
> 	<reporting>
> 		<plugins>
> 			<plugin>
> 				<groupId>org.codehaus.mojo</groupId>
> 				<artifactId>cobertura-maven-plugin</artifactId>
> 				<version>2.1</version>
> 					<configuration>
> 					  <includes>
> 						<include>**/*Test*.class</include>
> 					  </includes>
> 					  <formats>
> 						<format>html</format>
> 						<format>xml</format>
> 					  </formats>
> 					</configuration>
> 			</plugin>
> 		</plugins>
> 	</reporting>
> Please help me out. Please let me  know if you need any information from my side.
> Thanks
> Atanu Panda. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message