maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (SUREFIRE-660) Using testng with testng 5.14.2 add a dependency com.google.inject:guice which cannot be overriden
Date Mon, 15 Nov 2010 18:29:12 GMT

    [ http://jira.codehaus.org/browse/SUREFIRE-660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=243178#action_243178
] 

Olivier Lamy commented on SUREFIRE-660:
---------------------------------------

yes and no :-)
Because this trick doesn't with surefire 2.6.
So I didn't check which change has fixed that.

> Using testng with testng 5.14.2 add a dependency com.google.inject:guice which cannot
be overriden
> --------------------------------------------------------------------------------------------------
>
>                 Key: SUREFIRE-660
>                 URL: http://jira.codehaus.org/browse/SUREFIRE-660
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: TestNG support
>    Affects Versions: 2.6
>            Reporter: Olivier Lamy
>            Assignee: Olivier Lamy
>             Fix For: 2.7
>
>
> I use testng and want to use google guice 3.0-SNAPSHOT or sisu fork.
> But the version in my pom is not used, the testng dependency on com.google.inject:guice
is used first.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message