maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chad Lyon (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MASSEMBLY-452) Shared Assembly Descriptor does not work in Maven3-alpha4
Date Fri, 22 Oct 2010 19:52:44 GMT

    [ http://jira.codehaus.org/browse/MASSEMBLY-452?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=240659#action_240659
] 

Chad Lyon commented on MASSEMBLY-452:
-------------------------------------

Regression: This issue exists for version 2.2 of the plugin used with Maven 3.0!

I have to configure my poms to use 2.2-beta-5 of the assembly plugin to be able to use a shared
pom. It looks like 2.2 doesn't even try to search the classpath. Here is my env:

Apache Maven 3.0 (r1004208; 2010-10-04 07:50:56-0400)
Java version: 1.6.0_20
Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
Default locale: en_US, platform encoding: MacRoman
OS name: "mac os x" version: "10.6.4" arch: "x86_64" Family: "mac"

Please re-open this issue.

May I also suggest a unit/integration/regression test be added?



> Shared Assembly Descriptor does not work in Maven3-alpha4
> ---------------------------------------------------------
>
>                 Key: MASSEMBLY-452
>                 URL: http://jira.codehaus.org/browse/MASSEMBLY-452
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2-beta-4
>         Environment: Apache Maven 3.0-alpha-4 (r835944; 2009-11-13 13:06:31-0500)
> Java version: 1.6.0_16
> Java home: C:\java\jdk1.6.0_16\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows xp" version: "5.2" arch: "amd64" Family: "windows"
>            Reporter: Ben Tatham
>            Assignee: Benjamin Bentmann
>             Fix For: 2.2-beta-5
>
>         Attachments: assemblybug.txt
>
>
> Following these instructions: http://maven.apache.org/plugins/maven-assembly-plugin/examples/sharing-descriptors.html
> it used to work fine in Maven 2.2.1 and earlier.
> With Maven 3.0-alpha-4, see the attached output.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message