maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MSITE-515) site:site/site:deploy is mislinking modules
Date Tue, 19 Oct 2010 08:19:32 GMT

     [ http://jira.codehaus.org/browse/MSITE-515?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Herve Boutemy updated MSITE-515:
--------------------------------

    Description: 
Using 2.1, my parent POM looks like ...
{code:xml}
    <properties>
        <site.deploy.base>scp://hudson.basistech.net/home/projects/jug/jdd</site.deploy.base>
    </properties>
   <url>${url.base}</url>
 <distributionManagement>
        <site>
            <id>jdd.website</id>
            <url>${site.deploy.base}</url>
        </site>
    </distributionManagement>
{code}
and has a list of modules.

When I run mvn site:site site:deploy,

the resulting top-level page has links that look like:

{code:xml}
 <a href="../jdd-api/jdd-api/index.html" title="Jester Document Database API">Jester
Document Database API</a>
{code}

Note that the module name is in there, TWICE.



  was:
Using 2.1, my parent POM looks like ...
{code}
    <properties>
        <site.deploy.base>scp://hudson.basistech.net/home/projects/jug/jdd</site.deploy.base>
    </properties>
   <url>${url.base}</url>
 <distributionManagement>
        <site>
            <id>jdd.website</id>
            <url>${site.deploy.base}</url>
        </site>
    </distributionManagement>
{code}
and has a list of modules.

When I run mvn site:site site:deploy,

the resulting top-level page has links that look like:

{code}
 <a href="../jdd-api/jdd-api/index.html" title="Jester Document Database API">Jester
Document Database API</a>
{code}

Note that the module name is in there, TWICE.




> site:site/site:deploy is mislinking modules
> -------------------------------------------
>
>                 Key: MSITE-515
>                 URL: http://jira.codehaus.org/browse/MSITE-515
>             Project: Maven 2.x Site Plugin
>          Issue Type: Bug
>          Components: inheritance
>    Affects Versions: 2.1.1
>            Reporter: Benson Margulies
>
> Using 2.1, my parent POM looks like ...
> {code:xml}
>     <properties>
>         <site.deploy.base>scp://hudson.basistech.net/home/projects/jug/jdd</site.deploy.base>
>     </properties>
>    <url>${url.base}</url>
>  <distributionManagement>
>         <site>
>             <id>jdd.website</id>
>             <url>${site.deploy.base}</url>
>         </site>
>     </distributionManagement>
> {code}
> and has a list of modules.
> When I run mvn site:site site:deploy,
> the resulting top-level page has links that look like:
> {code:xml}
>  <a href="../jdd-api/jdd-api/index.html" title="Jester Document Database API">Jester
Document Database API</a>
> {code}
> Note that the module name is in there, TWICE.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message