maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ol (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MLINKCHECK-5) baseURL parameter does not work fine ???
Date Thu, 30 Sep 2010 12:58:32 GMT

    [ http://jira.codehaus.org/browse/MLINKCHECK-5?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=236969#action_236969
] 

ol commented on MLINKCHECK-5:
-----------------------------

Yes we tried with forceSite=true, but it's not a good solution for us because the builds of
the site is execute 2 times ... and we have lots of nightly builds ...

About profiles, linkcheck is not define in a profile, but lots of reporting plugins are defined
in the enterprise pom profiles.

It's difficult to give the test project, because we use an enterprise build (continuum, central
repo, enterprise wide pom, ...) with lots of customization. You will not be able to run the
build.

> baseURL parameter does not work fine ???
> ----------------------------------------
>
>                 Key: MLINKCHECK-5
>                 URL: http://jira.codehaus.org/browse/MLINKCHECK-5
>             Project: Maven 2.x Linkcheck Plugin
>          Issue Type: Bug
>    Affects Versions: 1.0.1
>         Environment: linux, continuum, maven-2.2.1
>            Reporter: ol
>
> I configure the plugin like the following:
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-linkcheck-plugin</artifactId>
>         <version>1.0.1</version>
>         <configuration>
>           <forceSite>false</forceSite>
>           <offline>false</offline>
>           <baseURL>http://myserver/${groupId}/${artifactId}</baseURL>
>           <excludedLinks>
>             <excludedLink>**/apidocs/*</excludedLink>
>             <excludedLink>**/cobertura/*</excludedLink>
>             <excludedLink>**/testapidocs/*</excludedLink>
>             <excludedLink>**/xref/*</excludedLink>
>             <excludedLink>**/xref-test/*</excludedLink>
>           </excludedLinks>          
>         </configuration>
>       </plugin>
> where the baseURL is the place where the site is deployed.
> Unfortunately, the report gives errors like that :
> pmd.html
> - ../index.html does not exists (but the parent site is published at http://myserver/${groupId})
> - ./css/print.css
> - project-info.html
> aso ... total of +7000 errors in my documentation site.
> What's wrong with my configuration ??
> I can see for example in the linkcheck.xml file this line :
>   <absolutePath>/data/continuum/1.3.4/9091/data/working-directory/12/target/site/pmd.html</absolutePath>
> Is it normal ??
> Thanks in advance !

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message