maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Briggs (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MRELEASE-519) release plugin fails on version ranges
Date Thu, 10 Jun 2010 15:47:12 GMT

    [ http://jira.codehaus.org/browse/MRELEASE-519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=224996#action_224996
] 

Jacob Briggs commented on MRELEASE-519:
---------------------------------------

We've been hit by the bug whilst attempting to upgrade to release plugin 2.0.  2.0-beta-8
does *not* have this issue, so it seems to affect the later beta and the final.

The presence of the artifact in the range locally or remotely does not affect the behaviour.

> release plugin fails on version ranges
> --------------------------------------
>
>                 Key: MRELEASE-519
>                 URL: http://jira.codehaus.org/browse/MRELEASE-519
>             Project: Maven 2.x Release Plugin
>          Issue Type: Bug
>          Components: prepare
>    Affects Versions: 2.0
>         Environment: Mac OS X 10.6, maven 2.2.1
>            Reporter: Stephen Cooper
>            Priority: Critical
>
> I have the following dependency in my pom.xml
>   <dependency>
>    <groupId>com.ften.protocols</groupId>
>    <artifactId>protocols</artifactId>
>    <version>[3.0.0,)</version>
>    <scope>compile</scope>
>   </dependency>
> I downloaded the source for maven-release 2.0 and installed locally.
> If I specify 2.0-beta-9, then mvn release:perform functions as it should.  If I specify
maven-release-plugin version 2.0, I get the following error:
> [INFO] Checking dependencies and plugins for snapshots ...
> [INFO] ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] version was null for com.ften.protocols:protocols
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> java.lang.NullPointerException: version was null for com.ften.protocols:protocols
> 	at org.apache.maven.artifact.DefaultArtifact.getBaseVersion(DefaultArtifact.java:390)
> 	at org.apache.maven.artifact.DefaultArtifact.isSnapshot(DefaultArtifact.java:562)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message