maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jochen Ehret (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (ARCHETYPE-318) <requiredProperty> <defaultValue> not correctly filtered
Date Thu, 17 Jun 2010 07:46:12 GMT
<requiredProperty> <defaultValue> not correctly filtered
--------------------------------------------------------

                 Key: ARCHETYPE-318
                 URL: http://jira.codehaus.org/browse/ARCHETYPE-318
             Project: Maven Archetype
          Issue Type: Bug
          Components: Generator
    Affects Versions: 2.0-alpha-5
            Reporter: Jochen Ehret
            Priority: Minor


In our archetype-metadata.xml we┬┤ve defined a <requiredProperty> with a default value
like this:

<requiredProperty key="subArtifactId">
    <defaultValue>${artifactId}.itest1</defaultValue>
</requiredProperty>

When we call "archetype:generate" and enter the parameters in interactive mode everything
works fine. But when we try to set the parameter "subArtifactId" on the command line (mvn
archetype:generate -DsubArtifactId=xyz) or from an "archetype.properties" file, the value
is ignored. In the generated pom.xml the variable ${subArtifactId} is always replaced with
"${artifactId}.itest1".

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message