maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ed Slocombe (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MRELEASE-556) Perform fails with 'working directory "...\workspace\target\checkout\workspace" does not exist!'
Date Wed, 12 May 2010 08:21:12 GMT
Perform fails with 'working directory "...\workspace\target\checkout\workspace" does not exist!'
------------------------------------------------------------------------------------------------

                 Key: MRELEASE-556
                 URL: http://jira.codehaus.org/browse/MRELEASE-556
             Project: Maven 2.x Release Plugin
          Issue Type: Bug
          Components: perform
    Affects Versions: 2.0
         Environment: Windows XP
            Reporter: Ed Slocombe


I have maven project that fails when release:perform is called, though release;prepare works
as expected.

I have found two bug reports which may be of relevance:

MRELEASE-261 -> Closed and fixed in version 2.0 but seems similiar
MRELEASE-516 -> Output of perform is identical


The last few lines of output I get:

{code}
[INFO] Executing: cmd.exe /X /C 
    "p4 -d E:\hudson\jobs\myHudsonJob\workspace\target\checkout -p 1.1.1.1:1111: 
    client -d myProjectWorkspace-MavenSCM-E:\hudson\jobs\myHudsonJob\workspace\target\checkout"
[INFO] Executing goals 'deploy'...
[WARNING] Base directory is a file. Using base directory as POM location.
[WARNING] Maven will be executed in interactive mode, but no input stream has been configured
for this MavenInvoker instance.
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error executing Maven.
    
Working directory "E:\hudson\jobs\myHudsonJob\workspace\target\checkout\workspace" does not
exist!
{code}


>From reading the aforementioned bug reports, the possible cause of the error may be related
to my modules' structure, I've tried to outline it below:

{code}
/workspace
|
|+ pom.xml (root pom whose parent is the build pom, 
|           calling release:perform on this pom)
|           [Modules: moduleA and moduleB]
|
|- moduleA
   |+ pom.xml (parent is also build pom)
   |+ build/pom.xml (the build pom - no custom parent)
|- moduleB
   |+ pom.xml (parent is build pom)
{code}


It seems that the root pom should be in some common directory inside 'workspace' from the
error but tried that and doesn't work, nor make sense as to why I need it.

It then figures that the base directory is *workspace* which then means the working directory
is not found...the working directory it should be using (having seen where everything is checked
out) is 'E:\hudson\jobs\myHudsonJob\workspace\target\checkout\'.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message