maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Theussl (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-470) Classpath (ex/im)plosion with site plugin 2.1
Date Mon, 12 Apr 2010 13:41:11 GMT

    [ http://jira.codehaus.org/browse/MSITE-470?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=217653#action_217653
] 

Lukas Theussl commented on MSITE-470:
-------------------------------------

This seems to duplicate MSITE-459, can you check if the workaround there helps anything?

> Classpath (ex/im)plosion with site plugin 2.1
> ---------------------------------------------
>
>                 Key: MSITE-470
>                 URL: http://jira.codehaus.org/browse/MSITE-470
>             Project: Maven 2.x Site Plugin
>          Issue Type: Bug
>    Affects Versions: 2.1
>            Reporter: Benson Margulies
>         Attachments: mvn.log
>
>
> I'm not sure how to chase this. I got here with mvn javadoc:javadoc javadoc:test-javadoc
site:site site:deploy
> {noformat}
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Manifest jar for training jobs
> [INFO] ------------------------------------------------------------------------
> [WARNING] Removing: check from forked lifecycle, to prevent recursive invocation.
> [INFO] [checkstyle:checkstyle {execution: validate}]
> [INFO] Preparing javadoc:javadoc
> [WARNING] Removing: check from forked lifecycle, to prevent recursive invocation.
> [INFO] [checkstyle:checkstyle {execution: validate}]
> [INFO] Starting audit...
> Audit done.
> [INFO] [site:site]
> [INFO] Parent project loaded from repository.
> [INFO] Generating "Dependency Convergence" report.
> [INFO] Generating "Project Plugins" report.
> [INFO] Generating "Project License" report.
> [INFO] Generating "Project Team" report.
> [INFO] Generating "Project Summary" report.
> [INFO] Generating "Continuous Integration" report.
> [INFO] Generating "About" report.
> [INFO] Generating "Issue Tracking" report.
> [INFO] Generating "Dependency Management" report.
> [INFO] Generating "Source Repository" report.
> [INFO] Generating "Plugin Management" report.
> [INFO] Generating "Mailing Lists" report.
> [INFO] Generating "Dependencies" report.
> [INFO] Generating "JavaDocs" report.
> [WARNING] Are you sure about the <javadocVersion/> parameter? It seems to be 1.6
> [FATAL ERROR] org.apache.maven.plugins.site.SiteMojo#execute() caused a linkage error
(java.lang.ExceptionInInitializerError) and may be out-of-date. Check the realms:
> [FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven-site-plugin:2.1]
> urls[0] = file:/Users/benson/.m2/repository/org/apache/maven/plugins/maven-site-plugin/2.1/maven-site-plugin-2.1.jar
> urls[1] = file:/Users/benson/.m2/repository/org/codehaus/plexus/plexus-utils/1.5.1/plexus-utils-1.5.1.jar
> urls[2] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-module-xhtml/1.1.2/doxia-module-xhtml-1.1.2.jar
> urls[3] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-core/1.1.2/doxia-core-1.1.2.jar
> urls[4] = file:/Users/benson/.m2/repository/xerces/xercesImpl/2.8.1/xercesImpl-2.8.1.jar
> urls[5] = file:/Users/benson/.m2/repository/xml-apis/xml-apis/1.3.03/xml-apis-1.3.03.jar
> urls[6] = file:/Users/benson/.m2/repository/commons-lang/commons-lang/2.1/commons-lang-2.1.jar
> urls[7] = file:/Users/benson/.m2/repository/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar
> urls[8] = file:/Users/benson/.m2/repository/commons-logging/commons-logging/1.0.4/commons-logging-1.0.4.jar
> urls[9] = file:/Users/benson/.m2/repository/commons-codec/commons-codec/1.2/commons-codec-1.2.jar
> urls[10] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-module-apt/1.1.2/doxia-module-apt-1.1.2.jar
> urls[11] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-module-xdoc/1.1.2/doxia-module-xdoc-1.1.2.jar
> urls[12] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-module-fml/1.1.2/doxia-module-fml-1.1.2.jar
> urls[13] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-decoration-model/1.1.2/doxia-decoration-model-1.1.2.jar
> urls[14] = file:/Users/benson/.m2/repository/org/apache/maven/doxia/doxia-site-renderer/1.1.2/doxia-site-renderer-1.1.2.jar
> urls[15] = file:/Users/benson/.m2/repository/org/codehaus/plexus/plexus-i18n/1.0-beta-7/plexus-i18n-1.0-beta-7.jar
> urls[16] = file:/Users/benson/.m2/repository/org/codehaus/plexus/plexus-velocity/1.1.8/plexus-velocity-1.1.8.jar
> urls[17] = file:/Users/benson/.m2/repository/org/apache/velocity/velocity/1.5/velocity-1.5.jar
> urls[18] = file:/Users/benson/.m2/repository/commons-collections/commons-collections/3.2/commons-collections-3.2.jar
> urls[19] = file:/Users/benson/.m2/repository/oro/oro/2.0.8/oro-2.0.8.jar
> urls[20] = file:/Users/benson/.m2/repository/org/apache/maven/shared/maven-doxia-tools/1.2/maven-doxia-tools-1.2.jar
> urls[21] = file:/Users/benson/.m2/repository/commons-io/commons-io/1.4/commons-io-1.4.jar
> urls[22] = file:/Users/benson/.m2/repository/org/codehaus/plexus/plexus-archiver/1.0-alpha-7/plexus-archiver-1.0-alpha-7.jar
> urls[23] = file:/Users/benson/.m2/repository/org/mortbay/jetty/jetty/6.1.5/jetty-6.1.5.jar
> urls[24] = file:/Users/benson/.m2/repository/org/mortbay/jetty/jetty-util/6.1.5/jetty-util-6.1.5.jar
> urls[25] = file:/Users/benson/.m2/repository/org/mortbay/jetty/servlet-api-2.5/6.1.5/servlet-api-2.5-6.1.5.jar
> [FATAL ERROR] Container realm = plexus.core
> urls[0] = file:/Users/benson/x/trunk/third-party-tools/maven/lib/maven-2.1.0-uber.jar
> [INFO] ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] null
> Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log'
visible, which is not allowed.
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> java.lang.ExceptionInInitializerError
> 	at org.apache.maven.plugin.javadoc.JavadocUtil.fetchURL(JavadocUtil.java:730)
> 	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.isValidJavadocLink(AbstractJavadocMojo.java:4680)
> 	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.addLinkArguments(AbstractJavadocMojo.java:3229)
> 	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.addStandardDocletOptions(AbstractJavadocMojo.java:3885)
> 	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.executeReport(AbstractJavadocMojo.java:1761)
> 	at org.apache.maven.plugin.javadoc.JavadocReport.generate(JavadocReport.java:122)
> 	at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:164)
> 	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.renderModule(DefaultSiteRenderer.java:328)
> 	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:132)
> 	at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:142)
> 	at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:109)
> 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:483)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:553)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:523)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:332)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:597)
> 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You
have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.
(Caused by org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.
 You have more than one version of 'org.apache.commons.logging.Log' visible, which is not
allowed.) (Caused by org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException:
Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log'
visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException:
Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log'
visible, which is not allowed.))
> 	at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:543)
> 	at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:235)
> 	at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:209)
> 	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:351)
> 	at org.apache.commons.httpclient.HttpClient.<clinit>(HttpClient.java:66)
> 	... 29 more
> Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException:
Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log'
visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException:
Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log'
visible, which is not allowed.)
> 	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:397)
> 	at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:529)
> 	... 33 more
> Caused by: org.apache.commons.logging.LogConfigurationException: Invalid class loader
hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which
is not allowed.
> 	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:385)
> {noformat}

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message