maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Francart (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MASSEMBLY-463) Assembly fails Problem creating war: JAR entry not found
Date Tue, 23 Feb 2010 13:44:55 GMT

    [ http://jira.codehaus.org/browse/MASSEMBLY-463?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=211287#action_211287
] 

Thomas Francart commented on MASSEMBLY-463:
-------------------------------------------

If we run maven with the "-o" switch, the problem is still here.

> Assembly fails Problem creating war: JAR entry not found
> --------------------------------------------------------
>
>                 Key: MASSEMBLY-463
>                 URL: http://jira.codehaus.org/browse/MASSEMBLY-463
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2-beta-5
>         Environment: CentOS or Debian, Java 6.0-16
>            Reporter: Mike Key
>         Attachments: distribution.xml, massembly-463.log, pom.xml
>
>
> When doing a build through hudson on either a Debian or CentOS machine (the only two
I've tested) the assembly plugin fails with a message like this:
> Failed to create assembly: Error creating assembly archive distribution: Problem creating
war: JAR entry [[filename.random]] not found in /path/to/war/extracted/from
> In this depending on what maven options are used, various different files show up as
not found in the war being extracted from to create the assembly.  However, the file ALWAYS
exists.
> This issue ONLY occurs when the build goals include the 'deploy' goal.  In other words,
if I run 'mvn clean package' or mvn clean install' the issue does not exist, but if I run
'mvn clean package deploy' or 'mvn clean install deploy' the assembly fails.
> Note that USUALLY, running another build seems to clear up the issue, but not always.
 But the issue does break out CI process.
> Attached is the assembly itself.  I was never able to associate any change to this assembly
contributing to the start of this issue.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message