maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Tran (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MDEP-203) Severe Errors are only logged as debug
Date Thu, 31 Dec 2009 01:14:57 GMT

     [ http://jira.codehaus.org/browse/MDEP-203?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dan Tran closed MDEP-203.
-------------------------

       Resolution: Won't Fix
    Fix Version/s: 2.2

> Severe Errors are only logged as debug
> --------------------------------------
>
>                 Key: MDEP-203
>                 URL: http://jira.codehaus.org/browse/MDEP-203
>             Project: Maven 2.x Dependency Plugin
>          Issue Type: Bug
>            Reporter: Michael Wenig
>            Assignee: Brian Fox
>             Fix For: 2.2
>
>
> Today I had surprisingly spurios problems occuring visually caused by missing dependencies.
> Interestingly I could download the artifact using all the urls (including our internal
nexus) provided and had no idea what the /&()/%& was going wrong.
> After a long time (and activating the debug flag) I found the problem: The dependency
WAS downloaded but could not be stored in the local repository because of some single bad
permissions in folders (there was a root calling a maven-build which leads to some folders
owned by root)
> [DEBUG] Unable to get resource 'jaxen:jaxen:jar:1.1.1' from repository central (http://repo1.maven.org/maven2):
Specified destination directory cannot be created: /data/apps/infrastructure/maven/repository/jaxen/jaxen/1.1.1
> Why the hell is such an error just logged as debug????? I think it should be logged in
error-scope - this had saved me a lot of time!
> Please check your logging according such problems.
> Additionally it would be helpful if any log message would be prepended by the name and
version of the plugin which creates it - actually I cannot even say which version of the dependency
plugin was used :-(
> This is the output without debug-flag - there is no hint that there were any local problems:
> Downloading: http://repository.codehaus.org//jaxen/jaxen/1.1.1/jaxen-1.1.1.pom
> Downloading: http://snapshots.repository.codehaus.org//jaxen/jaxen/1.1.1/jaxen-1.1.1.pom
> ..
> Downloading: http://repository.codehaus.org//jaxen/jaxen/1.1.1/jaxen-1.1.1.jar
> Downloading: http://snapshots.repository.codehaus.org//jaxen/jaxen/1.1.1/jaxen-1.1.1.jar
> ..
> ....
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> Missing:
> ----------
> 1) jaxen:jaxen:jar:1.1.1
>   Try downloading the file manually from the project website.
>   Then, install it using the command: 
>       mvn install:install-file -DgroupId=jaxen -DartifactId=jaxen -Dversion=1.1.1 -Dpackaging=jar
-Dfile=/path/to/file
>   Alternatively, if you host your own repository you can deploy the file there: 
>       mvn deploy:deploy-file -DgroupId=jaxen -DartifactId=jaxen -Dversion=1.1.1 -Dpackaging=jar
-Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>   Path to dependency: 
>   	1) org.apache.maven.plugins:maven-pmd-plugin:maven-plugin:2.4
>   	2) pmd:pmd-jdk14:jar:4.2.2
>   	3) jaxen:jaxen:jar:1.1.1
> ----------
> 1 required artifact is missing.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message