maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Milos Kleint (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MCOMPILER-80) Change default source level to 1.5
Date Wed, 23 Dec 2009 07:36:55 GMT

    [ http://jira.codehaus.org/browse/MCOMPILER-80?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=203912#action_203912
] 

Milos Kleint commented on MCOMPILER-80:
---------------------------------------

what old version of maven will actually be affected? meaning which one doesn't set version
numbers in super pom? 2.0.9 or older?

There is one big problem with the super-pom solution and that's embedding and IDE usage. So
we might end up with the IDE resolving the version differently than the cmd maven being used
later for building. Or the IDE somehow makes use of the super-pom of the cmd-line maven being
setup in the IDE. And then your newly created quickstart archetype will be either 1.4 or 1.5
depending on what cmd maven is on PATH?
In the case when we only change the default value in compiler plugin, the IDE can figure the
default value based on the version of the compiler plugin being used.

> Change default source level to 1.5
> ----------------------------------
>
>                 Key: MCOMPILER-80
>                 URL: http://jira.codehaus.org/browse/MCOMPILER-80
>             Project: Maven 2.x Compiler Plugin
>          Issue Type: Improvement
>            Reporter: Grzegorz Borkowski
>            Priority: Minor
>
> Deafult source level setting for Maven compiler plugin is 1.3, as far as I remember.
This makes no sense. 1.3 is used at this moment only in legacy applications. Probability of
porting such legacy application to Maven 2 is very small. I was working with such applications
- none of them used Maven. In fact, I don't know any application using Maven, which requires
level 1.3.  
> On the other hand, Maven is used exensively in new applications. Most of them use Java
5 features (annotations, generics...). All new applications I create use Maven 2 and Java
5. Every time I setup such application it makes me crazy that I get errors on my generics
and annoations, and I have to setup manually the source level to 1.5. Come on, we have year
2008, not 2000! Java 5 is here for several years already. So why Maven compiler plugin does
not use the most reasonable default approach, instead it still assumes we are in 2000 year?
If someone wants to use old java version, than he can change the source level. By default
should be 1.5.
> The default setting can be changed in never wersion of maven compiler plugin.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message