maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Gier (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MANTTASKS-161) SSH Wagon Provider for remote repository does not working with anttask deploy
Date Wed, 25 Nov 2009 23:40:55 GMT

    [ http://jira.codehaus.org/browse/MANTTASKS-161?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=199509#action_199509
] 

Paul Gier commented on MANTTASKS-161:
-------------------------------------

Can you upload a sample project to reproduce this?

> SSH Wagon Provider for remote repository does not working with anttask deploy
> -----------------------------------------------------------------------------
>
>                 Key: MANTTASKS-161
>                 URL: http://jira.codehaus.org/browse/MANTTASKS-161
>             Project: Maven 2.x Ant Tasks
>          Issue Type: Bug
>    Affects Versions: 2.0.10
>            Reporter: Richard Bock
>
> <artifact:deploy pomrefid="mypom" file="${build.dir}/sce.maven.jar">
> 	<remoteRepository url="scp://svne1.access.nokiasiemensnetworks.com/isource/mvnroot/SDF_SCE">
> 		<authentication username="${repository.username}"  password="${repository.password}"/>
>    	</remoteRepository>
> </artifact:deploy>
> This works when I create the full path in the remote server. When I do not create the
path I am getting the following error:
> deploy:
> [artifact:install-provider] Installing provider: org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
> [artifact:deploy] Deploying to scp://svne1.access.nokiasiemensnetworks.com/isource/mvnroot/SDF_SCE
> [artifact:deploy] Uploading: com/nsn/see/sce/core/maventools/5.0.0/maventools-5.0.0.jar
to remote
> [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
> [artifact:deploy]  Diagnosis:
> [artifact:deploy] 
> [artifact:deploy] Error deploying artifact 'com.nsn.see.sce.core:maventools:jar': Error
deploying artifact: SCP terminated with error: 'scp: /isource/mvnroot/SDF_SCE/com/nsn/see/sce/core/maventools/5.0.0/maventools-5.0.0.jar:
No such file or directory'
> [artifact:deploy] 
> BUILD FAILED
> D:\work\sce\sce\sce.maven\build.xml:127: Error deploying artifact 'com.nsn.see.sce.core:maventools:jar':
Error deploying artifact: SCP terminated with error: 'scp: /isource/mvnroot/SDF_SCE/com/nsn/see/sce/core/maventools/5.0.0/maventools-5.0.0.jar:
No such file or directory'
> Either I did not understand the example how to use the scp wagon and deploy task or the
wagon does not create the folder automatically before it uses scp to copy the files.
> In the first case please let me know how to fix this using a proper configuration and
in the second case can you provide a bugfix?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message