maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony Whitford (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MJAVADOC-276) Initial builds of a multi-module project fail
Date Fri, 27 Nov 2009 07:05:55 GMT
Initial builds of a multi-module project fail
---------------------------------------------

                 Key: MJAVADOC-276
                 URL: http://jira.codehaus.org/browse/MJAVADOC-276
             Project: Maven 2.x Javadoc Plugin
          Issue Type: Bug
    Affects Versions: 2.6.1
         Environment: Java jdk1.6.0_16, Maven 2.2.1, Windows Vista 64-bit
Java jdk1.6.0_05, Maven 2.0.9, Windows XP 32-bit
            Reporter: Anthony Whitford
            Priority: Blocker
         Attachments: bug.zip

I ran into a problem using Maven Javadoc Plugin 2.6.1 right after I released...  I went from
version 1.15 to 1.16-SNAPSHOT, and my 1.16-SNAPSHOT build failed ({{mvn clean install site}})
because Javadoc fails when run from the top-level parent.  When it is building _module A_,
the javadoc complains that _module B_ and _module C_ are missing -- of course they are, they
haven't been built yet.  Note that running {{mvn clean install}} from _module A_ works fine
-- the behavior is limited to running from the top-level parent -- AND, if you run a {{mvn
install}} for _module B_ and _module C_, then you have given it what it needs and so you won't
see the error.

The attached example exhibits the problem.  It was created from the _j2ee-simple_ archetype
-- I only added the explicit javadoc plugin declaration to the top level pom to control the
version being used.  To recreate the problem, unzip and simply:  {{mvn clean install site}}.
 You will get an error message like:

{noformat}
[INFO] Unable to find resource 'root.project.projects:logging:jar:1.0' in repository central
(http://repo1.maven.org/maven2)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) root.project.projects:logging:jar:1.0

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=root.project.projects -DartifactId=logging -Dversion=1.0
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there:

      mvn deploy:deploy-file -DgroupId=root.project.projects -DartifactId=logging -Dversion=1.0
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=
[id]

  Path to dependency:
        1) root.project:primary-source:jar:1.0
        2) root.project.projects:logging:jar:1.0

----------
1 required artifact is missing.

for artifact:
  root.project:primary-source:jar:1.0

from the specified remote repositories:
  central (http://repo1.maven.org/maven2)
{noformat}

As you can see, it seems to think that a submodule (in this case {{root.project.projects:logging:jar:1.0}})
is necessary to build the javadoc for the project...  Since this is the first time that this
is being built, the submodule does not exist (yet).

I have replicated this problem on two different computing environments, so I'm convinced that
the Maven version is not relevant.
(It is unclear to me if this problem also existed with Javadoc 2.6, but I don't think so.)


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message