maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MDEP-216) Specifying parameters on the command-line interface using -D syntax requires mdep refix.
Date Wed, 01 Jul 2009 08:13:05 GMT

    [ http://jira.codehaus.org/browse/MDEP-216?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=182101#action_182101
] 

Benjamin Bentmann commented on MDEP-216:
----------------------------------------

bq. According to the documentation however the "mdep." prefix is not needed
You probably misread the [documentation about the parameter|http://maven.apache.org/plugins/maven-dependency-plugin/copy-dependencies-mojo.html#failOnMissingClassifierArtifact],
it says {{Expression: ${mdep.failOnMissingClassifierArtifact}}}.

> Specifying parameters on the command-line interface using -D syntax requires mdep refix.
> ----------------------------------------------------------------------------------------
>
>                 Key: MDEP-216
>                 URL: http://jira.codehaus.org/browse/MDEP-216
>             Project: Maven 2.x Dependency Plugin
>          Issue Type: Bug
>          Components: copy-dependencies
>    Affects Versions: 2.0-alpha-1, 2.0-alpha-2, 2.0-alpha-3, 2.0-alpha-4, 2.0, 2.1, 2.2
>         Environment: Maven 2.0.9, dependency plugin 2.0.
>            Reporter: Rob ten Hove
>            Assignee: Brian Fox
>            Priority: Minor
>
> I used the dependency:copy-dependencies goal on the command-line, and wanted to set the
"failOnMissingClassifierArtifact" option to "false".
> Command-line used:
> mvn -Dclassifier=sources -DfailOnMissingClassifierArtifact=false -DoutputDirectory=x/y/z
dependency:copy-dependencies
> The problem is that the "failOnMissingClassifierArtifact" remained "true". This was also
visible after running maven in debug mode. After looking in the source code, I saw that the
"failOnMissingClassifierArtifact" class field was specified as '@parameter expression="${mdep.failOnMissingClassifierArtifact}"
default-value="true"'.
> The "outputDirectory" parameter however was specified as '@parameter expression="${outputDirectory}"
default-value="${project.build.directory}/dependency"'.
> Thus, without the "mdep." prefix.
> The outputDirectory worked so I changed the commandline to include the *mdep.* prefix:
> mvn -Dclassifier=sources -Dmdep.failOnMissingClassifierArtifact=false -DoutputDirectory=x/y/z
dependency:copy-dependencies
> Now it worked. According to the documentation however the "mdep." prefix is not needed,
and I would find it strange if it was needed. I think this problem is also true for other
parameters, maybe even for other goals.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message