maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ole Ersoy (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-584) No eclipse classpath entries generated for aspectj dependencies
Date Mon, 06 Jul 2009 18:29:22 GMT
No eclipse classpath entries generated for aspectj dependencies
---------------------------------------------------------------

                 Key: MECLIPSE-584
                 URL: http://jira.codehaus.org/browse/MECLIPSE-584
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Bug
          Components: Core : Dependencies resolution and build path (.classpath)
         Environment: Fedora 11
Sun Java
            Reporter: Ole Ersoy
            Priority: Minor


When I run eclipse:eclipse .classpath entries for the following elements don't get added:

        <dependency>
            <groupId>org.aspectj</groupId>
            <artifactId>aspectjrt</artifactId>
            <version>1.5.4</version>
        </dependency>
        
        <dependency>
            <groupId>org.aspectj</groupId>
            <artifactId>aspectjweaver</artifactId>
            <version>1.5.4</version>
        </dependency>

The dependencies are in the repository and I can add them manually myself like this:
  <classpathentry kind="var" path="M2_REPO/org/aspectj/aspectjrt/1.5.4/aspectjrt-1.5.4.jar"/>
  <classpathentry kind="var" path="M2_REPO/org/aspectj/aspectjweaver/1.5.4/aspectjweaver-1.5.4.jar"/>


I really thought this had to be a user error, so I tried taking some dependency declarations
that work, and just changing the body values to correspond with the bodies of the aspectj
dependency declarations.  It still does not work.



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message