maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNG-4143) Update Java requirement to 1.5
Date Wed, 10 Jun 2009 18:19:42 GMT

     [ http://jira.codehaus.org/browse/MNG-4143?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Casey closed MNG-4143.
---------------------------

    Resolution: Fixed

http://maven.apache.org/guides/mini/guide-building-jdk14-on-jdk15.html

This mini-guide will be deployed shortly, once I've added a little more documentation for
MNG-3203 and MNG-3401.

> Update Java requirement to 1.5
> ------------------------------
>
>                 Key: MNG-4143
>                 URL: http://jira.codehaus.org/browse/MNG-4143
>             Project: Maven 2
>          Issue Type: Task
>    Affects Versions: 2.1.0
>            Reporter: John Casey
>            Assignee: John Casey
>             Fix For: 2.2.0
>
>
> note that the required Java version for 2.1.1 has been upgraded to 1.5.
> JDK 1.4 will no longer be supported to _execute_ Maven. We'll need to document how to
configure toolchains, etc. to support _building_ 1.4 projects using a 1.4 JDK (to avoid api
incompatibilities with 1.5).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message