maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNG-4184) [regression] maven2.1 fails with cyclic dependency in case of extension/dependency for report-plugin to reactor-project
Date Thu, 04 Jun 2009 16:01:42 GMT

     [ http://jira.codehaus.org/browse/MNG-4184?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Casey updated MNG-4184:
----------------------------

    Fix Version/s: 2.2.0
          Summary: [regression] maven2.1 fails with cyclic dependency in case of extension/dependency
for report-plugin to reactor-project  (was: maven2.1 fails with cyclic dependency in case
of extension/dependency for report-plugin to reactor-project)

this sounds like a regression, and we'll need to either fix it or supply adequate documentation
for why compat with 2.0.x has been broken.

> [regression] maven2.1 fails with cyclic dependency in case of extension/dependency for
report-plugin to reactor-project
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: MNG-4184
>                 URL: http://jira.codehaus.org/browse/MNG-4184
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Dependencies
>    Affects Versions: 2.1.0
>            Reporter: Jörg Hohwiller
>             Fix For: 2.2.0
>
>
> In my project (https://m-m-m.svn.sourceforge.net/svnroot/m-m-m/trunk/)
> I am doing exactly what maven-checkstyle-plugin suggests as best practice for multi-module-builds:
> http://maven.apache.org/plugins/maven-checkstyle-plugin/examples/multi-module-config.html
> Howerver when I upgrade to maven 2.1 my build does not work anymore, while maven 2.0.10
works fine:
> [INFO] The projects in the reactor contain a cyclic reference: Edge between 'Vertex{label='net.sf.m-
> m-m:mmm-setup'}' and 'Vertex{label='net.sf.m-m-m:mmm-setup'}' introduces to cycle in
the graph net.s
> f.m-m-m:mmm-setup --> net.sf.m-m-m:mmm-setup
> Indeed the module mmm-setup inherits from the toplevel-pom and therefore has a maven-checkstyle-plugin
> with a dependency on itself. However this worked with maven 2.0.x and if this is NOT
going to be
> "fixed" in 2.1, you need to supply an acceptable workaround and update instructions such
as
> the one linked above. Please also note that such config-moudles (net.sf.m-m-m:mmm-setup
or 
> com.example.whizbang:build-tools) should typically be available in IDE and other modules
might
> depend on them so they have to be part of the reactor for eclipse:eclipse.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message