maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MASSEMBLY-416) outputDirectory default value in fileSet seems changed; now seems to use directory name of fileSet sourcedir
Date Thu, 04 Jun 2009 16:31:42 GMT

    [ http://jira.codehaus.org/browse/MASSEMBLY-416?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=179341#action_179341
] 

John Casey commented on MASSEMBLY-416:
--------------------------------------

Are you sure you're not having an issue with the plugin being in your local repository, and
not getting updated with the use of successive pluginRepositories? I've tried to reproduce
your results, using direct pastes of your original POM configuration and the basic project
from the quickstart archetype (modified to have junit as a compile-scope dependency)...and
I cannot reproduce it.

I'm going to attach this test project and the jar listing from running on my machine...can
you find out whether this is in line with what you're seeing? If this project doesn't reproduce
the problem for you, please see if you can make it do so. If it *does* reproduce the problem
on your end, consider deleting:

~/.m2/repository/org/apache/maven/plugins/maven-assembly-plugin

and retry.

> outputDirectory default value in fileSet seems changed; now seems to use directory name
of fileSet sourcedir
> ------------------------------------------------------------------------------------------------------------
>
>                 Key: MASSEMBLY-416
>                 URL: http://jira.codehaus.org/browse/MASSEMBLY-416
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2-beta-3
>            Reporter: John Casey
>            Assignee: John Casey
>            Priority: Blocker
>             Fix For: 2.2-beta-4
>
>
> From Grzegorz Slowikowski on the dev@maven mailing list ([VOTE] maven-assembly-plugin
2.2-beta-4 thread):
> {noformat}
> Hi
> With this configuration:
>    <pluginRepositories>
>        <pluginRepository>
>            <id>maven-staging-031</id>
>            <name>maven-staging-031</name>
>            <url>https://repository.apache.org/content/repositories/maven-staging-031</url>
>        </pluginRepository>
>    </pluginRepositories>
>    <build>
>        <plugins>
>            <plugin>
>                <groupId>org.apache.maven.plugins</groupId>
>                <artifactId>maven-assembly-plugin</artifactId>
>                <version>2.2-beta-4</version>
>                <configuration>
>                    <descriptorRefs>
>                        <descriptorRef>jar-with-dependencies</descriptorRef>
>                    </descriptorRefs>
>                </configuration>
>                <executions>
>                    <execution>
>                        <id>make-assembly</id>
>                        <phase>package</phase>
>                        <goals>
>                            <goal>single</goal>
>                        </goals>
>                    </execution>
>                </executions>
>            </plugin>
>        </plugins>
>    </build>
> I have "target" folder/package inside jar-with-dependencies archive which contains copies
of my project classes (they are in the normal
> package structure within this archive too).
> ...
> {noformat}

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message