maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-4143) Update Java requirement to 1.5
Date Fri, 01 May 2009 21:37:44 GMT

    [ http://jira.codehaus.org/browse/MNG-4143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=174926#action_174926
] 

John Casey commented on MNG-4143:
---------------------------------

The following configuration works for me:

{code:xml}
  <build>
    <pluginManagement>
      <plugins>
        <plugin>
          <artifactId>maven-compiler-plugin</artifactId>
          <version>2.0.2</version>
          <configuration>
            <source>1.4</source>
            <target>1.4</target>
          </configuration>
        </plugin>
      </plugins>
    </pluginManagement>
    
    <plugins>
      <plugin>
        <groupId>org.jvnet</groupId>
        <artifactId>animal-sniffer</artifactId>
        <version>1.2</version>
        <executions>
          <execution>
            <id>check-java-version</id>
            <phase>compile</phase>
            <goals>
              <goal>check</goal>
            </goals>
            <configuration>
              <signature>
                <groupId>org.jvnet.animal-sniffer</groupId>
                <artifactId>java1.4</artifactId>
                <version>1.0</version>
              </signature>
            </configuration>
          </execution>
        </executions>
      </plugin>
    </plugins>
  </build>
{code}

This is for a 1.4 project, obviously. Also, I've added the http://download.java.net/maven/2
repository to the nexus configuration I use for a local repoMgr/mirror. I'll write this up
in a mini-guide.

> Update Java requirement to 1.5
> ------------------------------
>
>                 Key: MNG-4143
>                 URL: http://jira.codehaus.org/browse/MNG-4143
>             Project: Maven 2
>          Issue Type: Task
>    Affects Versions: 2.1.0
>            Reporter: John Casey
>            Assignee: John Casey
>             Fix For: 2.2.0
>
>
> note that the required Java version for 2.1.1 has been upgraded to 1.5.
> JDK 1.4 will no longer be supported to _execute_ Maven. We'll need to document how to
configure toolchains, etc. to support _building_ 1.4 projects using a 1.4 JDK (to avoid api
incompatibilities with 1.5).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message