maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Heritier (JIRA)" <>
Subject [jira] Closed: (MECLIPSE-556) .properties files sometimes omitted when deploying a webapp project to Tomcat
Date Thu, 23 Apr 2009 10:09:44 GMT


Arnaud Heritier closed MECLIPSE-556.

    Resolution: Won't Fix

You have to open your issue here :
This project is for the eclipse:eclipse mojo in maven

> .properties files sometimes omitted when deploying a webapp project to Tomcat
> -----------------------------------------------------------------------------
>                 Key: MECLIPSE-556
>                 URL:
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: WTP support
>         Environment: m2eclipse and Maven Integration for WTP 0.9.6-20080905-0917
> Eclipse 3.4.1
> WST 3.0.2, WST Server Adapter 3.0.1
> Tomcat 5.5.27
>            Reporter: Jakub HolĂ˝
>         Attachments: org.eclipse.wst.common.component
> I have a manually created web project with the standard maven structure (src/main/webapp,
src/main/resources etc.). When I deploy the application to the server using Eclipse (Servers
view > Tomcat 5.5.27 > Add or Remove Projects... or Publish...) it happens sometimes
that .properties files (such as from src/main/resources are not copied to
the server.
> For some time everything worked correctly but then this problem appeared and I cannot
get rid of it. A friend had the same issue and solved it by not using the m2eclipse plugin
(he only used a maven goal to generate an Eclipse project from the maven project). This would
suggest that m2eclipse is the guilty one but on the other hand it could also be some random
corruption in project/Eclipse workspace.
> I don't know whether this is actually m2eclipse's or Eclipse's issue and would appreciate
advice how to find out more about the cause. 
> The strange thing is that this worked and now doesn't. Removing and Adding the webapp
to the project doesn't help, neither dies cleaning its tmp folder. The WST config file .settings/org.eclipse.wst.common.component
looks all right.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message