maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinh (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-543) custom properties not being evaluated before being referenced
Date Wed, 01 Apr 2009 23:59:13 GMT
custom properties not being evaluated before being referenced
-------------------------------------------------------------

                 Key: MECLIPSE-543
                 URL: http://jira.codehaus.org/browse/MECLIPSE-543
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Bug
            Reporter: Vinh


The following setup is not being handled correctly by the plugin, although it builds fine
from the command-line.  It seems to not evaluate the property definitions before applying
it to where the properties are referenced, both in the current pom and child poms.  The result
is that I must hard-code the version property throughout all my poms.  This becomes cumbersome
later on when I must change the version property value.

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
    <properties>
        <my.version>1.0-SNAPSHOT</my.version>
    </properties>
    <modelVersion>4.0.0</modelVersion>
    <groupId>com.test</groupId>
    <artifactId>common</artifactId>
    <packaging>pom</packaging>
    <name>common</name>
    <version>${my.version}</version>
...
</project>



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message