maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Costin Caraivan (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-531) eclipse:to-maven uses version ranges in pom.xmls created, which fail version checking
Date Thu, 05 Mar 2009 14:38:13 GMT
eclipse:to-maven uses version ranges in pom.xmls created, which fail version checking
-------------------------------------------------------------------------------------

                 Key: MECLIPSE-531
                 URL: http://jira.codehaus.org/browse/MECLIPSE-531
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Improvement
    Affects Versions: 2.5.1
         Environment: Windows XP SP3, Maven 2.0.9, Java 1.6.0.11
            Reporter: Costin Caraivan


If you use eclipse:to-maven, the resulting artifacts have poms containing versions like these,
for dependencies: [3.2.0,4.0.0).

End result =>

Couldn't find a version in [3.2.0-v3232o] to match range [3.2.0,4.0.0)

I believe that to-maven needs an option like make-artifacts, to resolveVersionRanges, because
stripping qualifiers means that we lose information (Eclipse 3.4 has some 3.2.0 plugins for
example, but with a different qualifier than the original 3.2 Eclipse plugins).

Or the version ranges need to be fixed, something like this: [3.2.0-, 4.0.0-).

Thank you.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message