maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trenton (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-4119) default profile is deactivated in pom
Date Mon, 30 Mar 2009 19:06:13 GMT

    [ http://jira.codehaus.org/browse/MNG-4119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=171431#action_171431
] 

Trenton commented on MNG-4119:
------------------------------

Thanks Benjamin.  Sorry for wasting your time. :P

> default profile is deactivated in pom
> -------------------------------------
>
>                 Key: MNG-4119
>                 URL: http://jira.codehaus.org/browse/MNG-4119
>             Project: Maven 2
>          Issue Type: Bug
>    Affects Versions: 2.0.10
>         Environment: linux, mvn 2.0.10
>            Reporter: Trenton
>            Assignee: Benjamin Bentmann
>
> In my pom, I have the following profiles...
>     <profile>
>       <id>nodebug</id>
>       <activation>
>         <activeByDefault>true</activeByDefault>
>       </activation>
>       <!--
>      Override this by creating a debug profile in settings.xml, and
>      doing mvn -Pdebug,profile1,profile2 install
>       -->
>       <properties>
>         <logger.level>INFO</logger.level>
>       </properties>
>     </profile>
>     <profile>
>       <id>skiptests</id>
>       <activation>
>         <activeByDefault>true</activeByDefault>
>       </activation>
>       <properties>
>         <maven.test.skip>true</maven.test.skip>
>       </properties>
>     </profile>
>     <profile>
>       <!-- activate this profile if you want to enable JUnit tests.  This
>            will override the same maven property in the skiptests -->
>       <id>test</id>
>       <properties>
>         <maven.test.skip>false</maven.test.skip>
>       </properties>
>     </profile>
> If I issue
> mvn -Plocal-aucm,inproc,local package
> everything works fine, and my log4j.properties loglevel is set to "INFO".
> If I issues...
> mvn -Ptest,local-aucm,inproc,local package
> My log4j.properties loglevel is set to "${logger.level}", without being filtered properly.
 So, it would seem that somehow my default active profile "nodebug" is deactivated when passing
in "test", and therefore the "logger.level" property does not get set.
> If I move the "test" profile to my settings.xml, everything works fine.
> If I pass "nodebug" or "debug" into the -P, it is also fine.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message