maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-4051) Default phase binding is not working
Date Wed, 25 Feb 2009 20:36:19 GMT

    [ http://jira.codehaus.org/browse/MNG-4051?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=167038#action_167038
] 

Benjamin Bentmann commented on MNG-4051:
----------------------------------------

I couldn't reproduce your issue here. Did you declare an {{<execution>}} element for
your goal in the POM? Just adding {{@phase ...}} is not enough.

> Default phase binding is not working
> ------------------------------------
>
>                 Key: MNG-4051
>                 URL: http://jira.codehaus.org/browse/MNG-4051
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Plugins and Lifecycle
>    Affects Versions: 2.0.10
>         Environment: Windows XP Pro SP2
> JDK 1.6.0_10
>            Reporter: Markus KARG
>            Priority: Critical
>
> The default phase binding is not working: My mojo contains @phase generate-resources,
what results in a phase entry in the plugin.xml. But it is not getting execute at mvn compile
(yes, there is no typo, I double checked. If I am adding an explicit phase binding (execution)
to the pom, it IS getting execute. So the default seems to do just nothing.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message