maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason van Zyl (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNG-3803) [regression] System properties not working any more
Date Thu, 29 Jan 2009 20:00:22 GMT

     [ http://jira.codehaus.org/browse/MNG-3803?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jason van Zyl updated MNG-3803:
-------------------------------

    Fix Version/s:     (was: 3.0-alpha-3)
                   3.0-alpha-4

> [regression] System properties not working any more
> ---------------------------------------------------
>
>                 Key: MNG-3803
>                 URL: http://jira.codehaus.org/browse/MNG-3803
>             Project: Maven 2
>          Issue Type: Bug
>    Affects Versions: 3.0-alpha-1
>            Reporter: Amélie Deltour
>            Priority: Minor
>             Fix For: 3.0-alpha-4
>
>
> Passing system properties to surefire-plugin used to work fine with Maven 2.0.9:
> {code:xml}
> <plugin>
>   <artifactId>maven-surefire-plugin</artifactId>
>   <configuration>
>     <systemProperties>
>       <property>
>         <name>my.property</name>
>         <value>my.value</value>
>       </property>
>     </systemProperties>
>   </configuration>
> </plugin>
> {code}
> Now I use Maven 2.1-SNAPSHOT as Embedder launched with m2eclipse.
> The properties are not defined any more.
> In the logs with Maven 2.0.9 in debug mode I see:
> [DEBUG] Setting system property [my.property]=[my.value]
> This line is not present in the logs with Maven 2.1.
> This compatibility issue is quite annoying...

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message