maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henrik Kaipe (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (SUREFIRE-519) junit-dep 4.4+ isn't detected - transitive dependency to JUnit-3.x causes POJO-test treatment
Date Sun, 21 Sep 2008 09:00:57 GMT
junit-dep 4.4+ isn't detected - transitive dependency to JUnit-3.x causes POJO-test treatment
---------------------------------------------------------------------------------------------

                 Key: SUREFIRE-519
                 URL: http://jira.codehaus.org/browse/SUREFIRE-519
             Project: Maven Surefire
          Issue Type: Bug
          Components: Junit 4.x support
    Affects Versions: 2.4.3
         Environment: $ mvn --version
Maven version: 2.0.9
Java version: 1.6.0_07
OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"
            Reporter: Henrik Kaipe
         Attachments: junitdep45-and-transitive-junit3-dependency.zip

Have a dependency to junit-dep version 4.4 or later and a transitive or optional dependency
to junit-3.8.1 and suddenly the fix for SUREFIRE-378 has been deceived. Your JUnit4 tests
will again be executed as if they were POJO-tests.

The attached maven-project reveals the bug.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message