maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Sandrini (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-406) Dependencies markes as <type>zip</type> don't get added to classpath
Date Wed, 19 Mar 2008 14:05:47 GMT
Dependencies markes as <type>zip</type> don't get added to classpath
--------------------------------------------------------------------

                 Key: MECLIPSE-406
                 URL: http://jira.codehaus.org/browse/MECLIPSE-406
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Bug
          Components: Core : Dependencies resolution and build path
            Reporter: Marco Sandrini


I have the following code in my pom.xml file

		<dependency>
			<groupId>com.mycompany</groupId>
			<artifactId>myzippedlibrary</artifactId>
			<version>1.1</version>
		        <type>zip</type>
			<scope>provided</scope>
		</dependency>

The artifact is correctly retrieved from our repository and everything looks fine, when running
maven from the command line, it is included in the correct classpath. The Maven Eclipse plugin,
though does not add the component to the .classpath therefore the syntax checker starts throwing
tons of error and the autocomplete features are not available.

Installed version = 0.9.0.20080310-1400-Sonatype (it was not selectable from the list of affects
version)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message