maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MPLUGIN-102) The 2.4 Release Breaks Previously-Working Builds
Date Wed, 19 Mar 2008 23:07:46 GMT

    [ http://jira.codehaus.org/browse/MPLUGIN-102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_127946
] 

Benjamin Bentmann commented on MPLUGIN-102:
-------------------------------------------

Caused by change for MPLUGIN-103 applied in [r543359|http://svn.apache.org/viewvc?view=rev&revision=543359].

> The 2.4 Release Breaks Previously-Working Builds
> ------------------------------------------------
>
>                 Key: MPLUGIN-102
>                 URL: http://jira.codehaus.org/browse/MPLUGIN-102
>             Project: Maven 2.x Plugin Tools
>          Issue Type: Bug
>          Components: Plugin Plugin
>    Affects Versions: 2.4
>         Environment: Maven version: 2.0.8
> Java version: 1.5.0_14
> OS name: "windows vista" version: "6.0" arch: "x86" Family: "windows"
>            Reporter: James Carman
>         Attachments: archetype-test.zip, debug.log
>
>
> We have an archetype contained within our project.  Today, when I tried to run our build,
I got the following error:
> [INFO] [plugin:descriptor]
> [INFO] Using 2 extractors.
> [INFO] Applying extractor for language: java
> [INFO] Extractor for language: java found 0 mojo descriptors.
> [INFO] Applying extractor for language: bsh
> [INFO] Extractor for language: bsh found 0 mojo descriptors.
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error extracting plugin descriptor: 'No mojo descriptors found in plugin.'
> However, if I add this to my pom.xml file for that module:
> <pluginManagement>
>   <plugins>
>     <plugin>
>       <groupId>org.apache.maven.plugins</groupId>
>       <artifactId>maven-plugin-plugin</artifactId>
>       <version>2.3</version>
>     </plugin>
>   </plugins>
> </pluginManagement>
> the build works just fine, as usual (understandable since the 2.4 release came out yesterday).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message