maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Damien Lecan (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MJAVADOC-116) Impossible to aggregate javadoc if snapshot never built
Date Thu, 06 Mar 2008 09:23:29 GMT

     [ http://jira.codehaus.org/browse/MJAVADOC-116?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Damien Lecan updated MJAVADOC-116:
----------------------------------

    Attachment: javadoc-plugin-test-case with classifier use.zip

Here is a test case which reproduces problem with classifiers and aggregated javadoc.

It is based on previous patch with following updates :
 - javadoc version 2.4-SNAPSHOT
 - build module 1 test jar ("test-jar" classifier)
 - module 2 depends on module 1 jar AND test-jar. They have to be declared together.

Try "mvn -DreleaseProfile=true clean deploy site-deploy", it will fail (maven 2.0.8)

Things to notice :
 - with aggregate = false, it works
 - in module 2, with exactly one of the 2 dependencies (jar OR test-jar), it works (??)

Is it enough to reproduce bug ?

> Impossible to aggregate javadoc if snapshot never built
> -------------------------------------------------------
>
>                 Key: MJAVADOC-116
>                 URL: http://jira.codehaus.org/browse/MJAVADOC-116
>             Project: Maven 2.x Javadoc Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2
>            Reporter: Damien Lecan
>            Assignee: Vincent Siveton
>             Fix For: 2.4
>
>         Attachments: javadoc-plugin-test-case with classifier use.zip, javadoc-plugin-test-case.zip,
log.txt
>
>
> In a multi-module projet, I build an aggregated Javadoc for the site.
> The project is built with "mvn clean deploy site-deploy"
> When I add a new project, the next build always fails because the javadoc plugin can't
find at least one snapshot for the new added module
> In the following example, I added a new module tele.persistance:pers-commons, which have
never been built before.
> Maven tries to download it but it can't find it (never build before).
> {noformat} [INFO] [site:site]
> [WARNING] Unable to load parent project from repository: Could not find the model file
'/continuum-folders/working-directory/116/../pom.xml'.
> [INFO] Skipped "About" report, file "index.html" already exists for the English version.
> [ERROR] VM #displayTree: error : too few arguments to macro. Wanted 2 got 0
> [ERROR] VM #menuItem: error : too few arguments to macro. Wanted 1 got 0
> [INFO] Generate "JavaDocs" report.
> [INFO] snapshot tele:commons:1.2.0-alpha-1-SNAPSHOT: checking for updates from mirror.snapshots
> [INFO] snapshot tele.persistance:pers-data:1.2.0-alpha-1-SNAPSHOT: checking for updates
from mirror.snapshots
> [INFO] snapshot tele.persistance:pers-api:1.2.0-alpha-1-SNAPSHOT: checking for updates
from mirror.snapshots
> [INFO] snapshot tele.persistance:pers-commons:1.2.0-alpha-1-SNAPSHOT: checking for updates
from mirror.snapshots
> Downloading: http://proxy/maven2-snapshots/repository/tele/persistance/pers-commons/1.2.0-alpha-1-SNAPSHOT/pers-commons-1.2.0-alpha-1-SNAPSHOT.jar
> [WARNING] Unable to get resource 'tele.persistance:pers-commons:jar:1.2.0-alpha-1-SNAPSHOT'
from repository mirror.snapshots (http://proxy/maven2-snapshots/repository)
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> Missing:
> ----------
> 1) tele.persistance:pers-commons:jar:1.2.0-alpha-1-SNAPSHOT
>   Try downloading the file manually from the project website.
>   Then, install it using the command: 
>       mvn install:install-file -DgroupId=tele.persistance -DartifactId=pers-commons \
>           -Dversion=1.2.0-alpha-1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>   Path to dependency: 
>   	1) tele.persistance:pers-dao:jar:1.2.0-alpha-1-SNAPSHOT
>   	2) tele.persistance:pers-commons:jar:1.2.0-alpha-1-SNAPSHOT
> ----------
> 1 required artifact is missing.
> for artifact: 
>   tele.persistance:pers-dao:jar:1.2.0-alpha-1-SNAPSHOT
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   mirror.snapshots (http://proxy/maven2-snapshots/repository)
> {noformat}
> If I make an intermediate "install", everything works fine

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message