maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Fabulich (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (SUREFIRE-459) Integration test using Jetty and JSP 2.1 fails after update to maven-surefire-plugin 2.4
Date Wed, 20 Feb 2008 05:57:28 GMT

     [ http://jira.codehaus.org/browse/SUREFIRE-459?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dan Fabulich closed SUREFIRE-459.
---------------------------------

    Resolution: Fixed

Marking Fixed

> Integration test using Jetty and JSP 2.1 fails after update to maven-surefire-plugin
2.4
> ----------------------------------------------------------------------------------------
>
>                 Key: SUREFIRE-459
>                 URL: http://jira.codehaus.org/browse/SUREFIRE-459
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: classloading, plugin
>    Affects Versions: 2.4, 2.4.1
>         Environment: Maven 2.0.8, Windows XP
>            Reporter: Nils-Helge Garli
>
> We have an integration test running in a Struts 2 sample application, and after the maven-surefire-plugin
was updated from 2.3 to 2.4, the test is failing. There's an issue registered in the Struts
2 JIRA explaining the error: https://issues.apache.org/struts/browse/WW-2494
> I have no idea what's causing the error, but I suspect it has something to do witn classloader
configuration, as aparently no tld files are found inside the jar files on the classpath.
> It should be pretty easy to reproduce. Just checkout the Struts 2 code and run 'mvn test'
on the portlet example application.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message