maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard van Nieuwenhoven (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MECLIPSE-361) eclipse plugin and WTP generating warnings in Europa
Date Tue, 18 Dec 2007 08:58:59 GMT

    [ http://jira.codehaus.org/browse/MECLIPSE-361?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_117179
] 

Richard van Nieuwenhoven commented on MECLIPSE-361:
---------------------------------------------------

The problem is that this warning is correct and the behavior is intended. The eclipse plugin
works on a per project basis, So it will not export the dependencies, every projects gets
the correct dependencies from the dependency resolution. 

So our issue here is how to tell eclipse that it's OK, and we know and we want it that way.

> eclipse plugin and WTP generating warnings in Europa 
> -----------------------------------------------------
>
>                 Key: MECLIPSE-361
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-361
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: WTP support
>    Affects Versions: 2.5
>         Environment: Eclipse 3.3.1.1 and WTP 2.0.1 Using Maven 2.0.7 and the last maven-eclipse-plugin
2.5-SNAPSHOT
>            Reporter: Yann Albou
>            Priority: Minor
>         Attachments: wtpTest.zip
>
>
> The issue is regarding warnings in Europa and WTP:
> "Classpath entry M2_REPO/log4j/log4j/1.2.13/log4j-1.2.13.jar will not be exported or
published. Runtime ClassNotFoundExceptions may result."
> 1) If I try to generate with wtpversion=1.5 and maven-eclipse-plugin
>  version 2.5-SNAPSHOT => I get the same behaviour in EUROPA (WARNINGS)
> 2) If I try to generate with wtpversion=1.5 and maven-eclipse-plugin
>  version 2.4 => I get the same behaviour in EUROPA (WARNINGS)
> 3) I then try using Eclipse 3.2.2 with WTP 1.5.3 (instead of Eclipse
>  3.3.1.1 and WTP 2.0.1) with maven-eclipse-plugin version 2.4 or
>  2.5-SNAPSHOT => Everything is perfect, no more warnings 
> I create a simple test in order to reproduce the issue.
> This test is a multi module application composed of 1 Ejb module and 1 Ear module.
> So at the top level Just run "mvn install eclipse:eclipse"
> And then in an europa workspace import the projetcs and you should see the warnings on
the EJB module.
> It will behave the same way if it exists other modules.
> I notice that, in the case you update parameters on the eclipse plugin you will need
to remove projects from workspace and import them again.
> otherwise some old parameter will stay in the eclipse cache...
> let me know if you need other tests
> Yann.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message