maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mykel Alvis (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MANTTASKS-6) ant artifact doesn't read settings.xml
Date Tue, 07 Aug 2007 14:28:13 GMT

    [ http://jira.codehaus.org/browse/MANTTASKS-6?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_104200
] 

Mykel Alvis commented on MANTTASKS-6:
-------------------------------------

I'm experiencing issues with this.

Is this "Fixed" in 2.0.7 ?  

ant -v reports the following on install-provider and hangs

[mykel@DHBHDTBLDCTRLAH ExampleAntMavenProject]$ ant -v
Apache Ant version 1.6.5 compiled on June 2 2005
Buildfile: build.xml
Detected Java version: 1.5 in: /usr/java/jdk1.5.0_12/jre
Detected OS: Linux
parsing buildfile /home/mykel/workspace-tutorial/ExampleAntMavenProject/build.xml with URI
= file:///home/mykel/workspace-tutorial/ExampleAntMavenProject/build.xml
Project base dir set to: /home/mykel/workspace-tutorial/ExampleAntMavenProject
 [property] Loading /home/mykel/workspace-tutorial/ExampleAntMavenProject/build.properties
Build sequence for target(s) `all' is [init, maven-setup, resolve-dependencies, compile, package,
install, all]
Complete build sequence is [init, maven-setup, resolve-dependencies, compile, package, install,
all, deploy-subordinate, deploy-release, clean, deploy-snapshot, ]

init:

maven-setup:
      [get] Getting: http://sirdsite/installs/maven-ant-tasks/maven-ant-tasks-2.0.7.jar
      [get] To: /home/mykel/workspace-tutorial/ExampleAntMavenProject/lib/maven- ant-tasks-2.0.7.jar
      [get] Not modified - so not downloaded
parsing buildfile jar:file:/home/mykel/workspace-tutorial/ExampleAntMavenProject/lib/maven-ant-tasks-2.0.7.jar!/org/apache/maven/artifact/ant/antlib.xml
with URI = jar:file:/home/mykel/workspace-tutorial/ExampleAntMavenProject/lib/maven-ant-tasks-2.0.7.jar!/org/apache/maven/artifact/ant/antlib.xml
     [echo] Installing Provider
[artifact:install-provider] Using remote repositories:
  - id=central, url=http://repo1.maven.org/maven2, releases=enabled, snapshots=disabled
[artifact:install-provider] Loading Maven settings file: /home/mykel/.m2/settings.xml

ant appears to hang at this point.

> ant artifact doesn't read settings.xml
> --------------------------------------
>
>                 Key: MANTTASKS-6
>                 URL: http://jira.codehaus.org/browse/MANTTASKS-6
>             Project: Maven 2.x Ant Tasks
>          Issue Type: Bug
>    Affects Versions: 2.0.6
>         Environment: winxp
>            Reporter: Brian Fox
>             Fix For: 2.0.7
>
>         Attachments: MANTTASKS-6.diff
>
>
> We are using an ant script to call maven deploy to auto deploy jar, pom and md5's and
sh1's for 3rd party libraries to our remote repository. The maven deploy ant task isn't using
the settings to find our mirrors or repositories for download. We have a parent pom that it
should find, but it's not. The settings.xml is in maven/conf and in HOME/.m2/ and in HOME/.ant/
> The repositories are defined in our pom file, but the login information needs to be in
the settings.xml. When we run this, it isn't finding the login information from settings.
We also had an issue where the remote repositories where defined in settings and it wasn't
working until we moved it to the pom. The underlying problem seems to be that settings isn't
taken into account in either case.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message