maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Heritier (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MECLIPSE-266) plugin applies java facet to ear project
Date Tue, 10 Jul 2007 06:55:13 GMT

    [ http://jira.codehaus.org/browse/MECLIPSE-266?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_101752
] 

Arnaud Heritier commented on MECLIPSE-266:
------------------------------------------

FYI the code used to resolve JEE versions is here : http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-eclipse-plugin/src/main/java/org/apache/maven/plugin/ide/JeeUtils.java
If you want to have a look at it and propose a patch ;-)

> plugin applies java facet to ear project
> ----------------------------------------
>
>                 Key: MECLIPSE-266
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-266
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: WTP support
>    Affects Versions: 2.3
>         Environment: Windows XP
>            Reporter: Srepfler Srgjan
>
> In .settings/org.eclipse.wst.common.project.facet.core.xml of the EAR module I'm getting
this:
> <faceted-project>
>   <fixed facet="jst.java"/>
>   <fixed facet="jst.ear"/>
>   <installed facet="jst.ear" version="1.3"/>
>   <installed facet="jst.java" version="1.4"/>
> </faceted-project>
> This is a wrong facet on a EAR module and I can't compile if I don't edit this file manually
(I can't do it from the project properties - facets dialog)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message